DPMS doesn't work properly - monitor switches back on

I am using Ubuntu 16.04 (JetPack 3.1) on TX1. Unfortunately I experience the following issue - after a period of inactivity the monitor goes off (as intended), but after roughly 10 seconds it turns on again completely blackened (with a mouse cursor visible).

I have experimented a lot so far:

  • Tried to disable gnome-screensaver (including “chmod -x /usr/bin/gnome-screensaver”)
  • Experimented with “xset dpms” settings and “xset s” settings

Nothing helped. The monitor just turns back on. I read about vbetool, but it’s not available on Arm64.

Any ideas/hints what to try? As it seems the problem is somewhere in X11, not in Gnome as even “xset dpms force off” doesn’t work properly.

Especially weird - after “xset s noblank; xset dpms force off” the screen turns back on with a strange grey picture.
After “xset s noexpose; xset dpms force off” the screen turns on again and shows the desktop, but after hitting a key it turns for 1-2 seconds off again and then on.

“xset s off” doesn’t help either.

I’ve also tried:
setterm -blank 5 -powersave powerdown -powerdown 5

Which resulted in:
setterm: terminal xterm-256color does not support --blank
setterm: cannot (un)set powersave mode: Inappropriate ioctl for device

This is the contents of my xorg.conf file:

Section "Module"
   Disable "dri"
   SubSection "extmod"
   Option "omit xfree86-dga"

Section "Device"
  Identifier "Tegra0"
  Driver "nvidia"
  Option "AllowEmptyInitialConfiguration" "true"

Section "Monitor"
  Identifier "DSI-0"
  Option "Ignore"

Many thanks for any help!!!

Hi alexander1jklh,

Do you mean your TX1 never go into suspend? Are you using TX1 devkit + HDMI?

Hi alexander1jklh,

We tried below command works on TX1/JetPack3.1:

sudo xset s off -dpms


Yes, monitor attached to TX1 never goes into suspend. As described it remains just black with a visible mouse cursor. I checked all possible settings, but as said - the monitor turns off for about 10 seconds as intended (after 5 minutes of inactivity), but then it just turns on again and remains black. I am using TX1 devkit + HDMI.

This command disables both screensaver and DPMS, why should I use it then? My goal is that DPMS works properly and the monitor turns off after 5 minutes of inactivity.


Hi alexander1jklh,

Sorry for misunderstand you question.
If you want to enter SC7 suspend mode, you can use below command:

root@tegra-ubuntu:~# echo mem > /sys/power/state

Device goes into LP0 state.

Thanks, I will try it. But how to automate it so the monitor turns off automatically after a certain inactivity period?

So, I just tried this, and it resulted in the following error:

bash: echo: write error: Device or resource busy

In addition: I tried to uninstall gnome-screensaver and install xscreensaver - same problem.

Maybe this will help, from Xorg.0.log :

[ 9.212] (EE) NVIDIA(0): Failed to allocate NVIDIA Error Handler
[ 9.213] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[ 9.213] (II) NVIDIA(0): may not be running or the “AcpidSocketPath” X
[ 9.213] (II) NVIDIA(0): configuration option may not be set correctly. When the
[ 9.213] (II) NVIDIA(0): ACPI event daemon is available, the NVIDIA X driver will
[ 9.213] (II) NVIDIA(0): try to use it to receive ACPI event notifications. For
[ 9.213] (II) NVIDIA(0): details, please see the “ConnectToAcpid” and
[ 9.213] (II) NVIDIA(0): “AcpidSocketPath” X configuration options in Appendix B: X
[ 9.213] (II) NVIDIA(0): Config Options in the README.
[ 9.275] (II) NVIDIA(0): Setting mode “DFP-0:nvidia-auto-select”
[ 9.699] (==) NVIDIA(0): Disabling shared memory pixmaps
[ 9.699] (==) NVIDIA(0): Backing store enabled
[ 9.699] (==) NVIDIA(0): Silken mouse enabled
[ 9.720] (==) NVIDIA(0): DPMS enabled

ACPI error could theoretically lead to such misbehavior - how this could be fixed?

EDIT: installed acpid package, the error is gone, but the general misbehavior remains.
BTW, maybe it’s important to mention that I am using a monitor with 3 connected signal sources, Jetson is one of them.

If your xorg.conf has something our driver is not able to recognize, ACPI error would show. So it is not that useful to identify the cause from it.

In fact, I cannot reproduce this issue on my device, so I would like to ask… Have you ever installed something affect x11?

Could you share dmesg and Xorg.0.log? I would like to see the log between suspension starts and over.

I just checked it with internal team. We indeed have such case. Such error is specific to some monitors.

That is why we cannot reproduce your issue here. Do you have other HDMI can verify?