DPMS not working on GTX980 with DisplayPort connection

352.41 still had the issue. changed to 346.96 = works fine.

Also on Gentoo. GeForce 980 GTX + Dell U3014 and was getting the exact same issue. My Dell U3011 which acts as the left monitor does not get this issue. Downgrading to 346 solves this.

I tried upgrading to 358.09 and still had the issue. 346.96 (346.96-r1) is where to be for now if you own a monitor like mine (Dell U3014).

I’ve the same problem on Kubuntu 15.10:

ii nvidia-352 352.41-0ubuntu1 amd64 NVIDIA binary driver - version 352.41

Monitor: Dell U2711

From reading this thread looks like I have the same issue with driver 352.41 on Ubuntu 15.10. The monitor does not enter energy save mode nor does it shutdown the backlight on xset dpms force off.


  • Nvidia Driver 352.41
  • Ubuntu 15.10 - kernel 4.2.0-16-generic
  • NVS 310 card
  • Dell UP2414Q monitor on DisplayPort

I reverted just the Nvidia driver to 340.93 and it works as expected. Please fix.

I’m having the same problem over HDMI:

  • nvidia-352 (352.41-0ubuntu1)
  • Ubuntu 15.10 - kernel 4.2.0-16-generic
  • MSI GTX950
  • Vizio M49-C1

FYI, I can get the output working again by moving the screen to the DisplayPort output (with dp-HDMI adapter) and then back to the HDMI output on the card.

I just upgraded to a 980ti and 352.55 on Debian Jessie and have encountered this issue with multiple monitors.

I’m currently running 4 monitors:

DisplayPort x 2 (Dell U2410, Dell U3011)
DVI x 1 (BenQ 241W)
HDMI x 1 (Vizio M49-CT)

The DVI and HDMI ports are turning off with DPMS but the DisplayPort connections are only blanking.

I was previously running a 3 monitor setup on a 660ti with driver version 340.65 in the following configuration and never had any DPMS issues:

DisplayPort x 1 (Dell U3011)
DVI x 2 (BenQ 241W, Dell U2410)

fyi - just found this post as I had the same issue.
I have a new Dell U3415W connected to a GTX 980 via the Dell provided displayport cable, using DP 1.2
I thought you might be interested to learn that it seems to have been an NVIDIA regression - fixed in Version: 352.63 (released 16/11/2015)
“Fixed a regression that prevented DPMS from working correctly on some DisplayPort displays.”

all working fine for me now (so far!)

Yeah, same here sadly. It’s been like it since the 352.xx release IIRC. GPU is: NVIDIA GPU GeForce GTX 670 (GK104) at PCI:1:0:0 (GPU-0)

The DVI and HDMI displays turn off correctly, the DP one (Ancor Communications Inc ASUS PB278) doesn’t - the screen blanks but doesn’t turn off.

I’m on an updated Arch install so everything else should be current.

@aplattner: if you need anything else let me know :)

Hi all, Did you test with 352.63 driver ? Release Highlights : Fixed a regression that prevented DPMS from working correctly on some DisplayPort displays.

Well I can’t remember what 352.xx release I had but I’m running 355.11 now - so if it was fixed it’s broken again now.

Just replying with a “me too” as well, 358.09 still has the DPMS issue with my monitor (NEC PA301W).

352.63 is newer than both of those.

There’s multiple branches of the driver:
352.x - long term stable
355.x - current/newest
358.x - beta

each gets new releases.

352.63 is dated Nov 16th.

both the latest 355.x and 358.x versions are from Oct. without the DPMS fixes yet.

That explains a bit. When will those fixes get merged back into the beta branches?

@ kamikaze22,

I’ve tested the 352.63 driver today - with Gentoo AMD64 on my ASUS ROG G751JT notebook.

Nice work! The notebook built-in display (DP connected) resumes from DPMS suspend correctly now. Plus you haven’t broken resume - from suspend to RAM (which is nice)!

I was previously stuck on 352.30 - the most recent working Nvidia driver for my system…

Btw I’ve just noticed the driver release notes don’t indicate what version of Linux kernel is officially supported by the driver… Do you happen to know if the 4.2.x series kernels are supported yet?


Why does the 358.16 (2015.11.20) changelog not mention the DPMS fix that the 352.63 (2015.11.16) driver has?

Does it have the fix and just forgot to mention it in the log?

358.16 does appear to have the fix even though it’s not in the changelog.

Yup 358.16 [2015.11.20] supports DPMS correctly for my DisplayPort connected laptop screen (ASUS ROG G751JT) and suspend-to-ram is working correctly… Finally!!

Still an issue on 375.66, I have to get the second DisplayPort monitor to go off by running “xset dpms force off” multiple consecutive times, but then I can’t get it to come back on again when it finally does turn off.