Drive AGX not booting up after flashing Drive Sdk 10.0

Please provide the following info (check/uncheck the boxes after clicking “+ Create Topic”):
Software Version
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
[yes] NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System
[yes] Linux

Hardware Platform
[yes] NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version
[yes] other

Host Machine Version
[yes] native Ubuntu 18.04
other (2.1 MB)

Dear @mukilan.vijayakumar,
May I know what DRIVE release was on target before flashing DRIVE SW 10.0?
Is the board in good working condition before flashing or it has any issues?
Could you remove ~/.nvsdkm folder, check flashing again and share fresh logs?

Drive was flashed with Drive SDK 5.2.0 and then I have tried installing 5.2.6, there I was not able to get Ubuntu desktop properly once it came after reboot it was not coming and I was not able flash again always it stops at 99.9. Hence I have tried flashing Drive SW 10.0 flash was successful 100% but not booting up. Now I am not able flash Drive Sw 10.0 again or go back to 5.2.6 always flash hangs at 99.9 and never succeed.

I will try by removing ~/.nvsdkm folder and share fresh logs.

Dear @mukilan.vijayakumar,
So the board has DRIVE OS 5.2.6? Could you access the target via minicom? If so, You can install ubuntu-desktop package manually in DRIVE OS 5.2.6 to get GUI.
May I know if you got DRIVE OS 5.2.6 via early access?

Dear Siva,

yes Board was flashed with Drive OS 5.2.6, but I dont think it was properly installed, when I try to install ubuntu-desktop faced lot of unmet dependencies issues which was difficult to resolve as it was keep on going for lot of dependencies, so though of reflashing that time also flash stuck at 99.9 however when I reboot I could able to access minicom and install ubuntu desktop once it came after reboot it was not coming and manually also I was not able bring ubuntu desktop or unity up. And was not able to reflash 5.2.6 again so thought of coming back to SW 10.0 from then I had this booting issue.

Drive OS 5.2.6 was visible SDK Manager for Nvidia Partner login, hence tried it.

Dear Siva,

Please let me know why flash hangs at 99.9 and how to bring the board up now with any of the Sdk

Dear @mukilan.vijayakumar,
Forum is intended to support only Devzone releases. Also, Note that, moving from DRIVE OS 5.2.6 → DRIVE SW 10.0 is not supported. Please check migration support matrix in Getting Started: DRIVE OS :: DRIVE Platform Installation Guide with NVIDIA SDK Manager. Please check with your NVIDIA representative for support on this.

Dear Siva,

But I am not able to reflash 5.2.6 also any idea why it stops at 99.9.

Dear Siva,

issue is because flashing from 5.2.0 to 5.2.6 directly instead of going like 5.2.0 → →

Dear @mukilan.vijayakumar,
Could you please contact your NVIDIA representative for support on NVONLINE releases.

issue is because flashing from 5.2.0 to 5.2.6 directly instead of going like 5.2.0 → →

Yes. 5.2.0 → 5.2.6 is not supported for NVONLINE releases.

Dear Siva, Thanks.

Dear Siva,

Can you please let us know how to contact Nvidia representative or whom to contact.

Dear @mukilan.vijayakumar,
Please check your inbox

Hi @mukilan.vijayakumar ,

For installing back DRIVE Software 10 not booting, please see if the following topic helps. Thanks.

Hi VickNV,

Issue I am facing is different, Board is not Booting actually with Drive Software 10 and I am not able to flash any other SW Drive OS 5.2.0 or 5.2.6. Issue is because of flashing from 5.2.0 to 5.2.6.

After flashing since board is not flashing cant access Minicom as well.

For DRIVE Software 10.0, have you actually installed/flashed it successfully? I cannot find any message in your log showing it’s complete.
Did you run SDK Manager on native ubuntu 18.04 and following Getting Started with DRIVE Software :: NVIDIA DRIVE AGX System Installation and Setup?

Once it got success actually but was not booting, whenever I try to reinstall it used to stuck at 99.90 always when I tried to flash any 10 or 5.2.0 or 5.2.6

For DRIVE Software 10.0, because your log looks not installed successfully, please remove ~/.nvsdkm and reinstall it. If still problems, provide us the new log.

For, your log looks you ran other minicom-like application at the same time occuping the port so it didn’t install successfully.

Shall we install from 5.2.6 to 10? is downgrade possible?
Siva said like we cannot go from 5.2.0 to 5.2.6 using NVonline and we cannot come back from 5.2.6 to 10 Software.

I have already tried installing once by removing ~/.nvsdkm, same issue flash stops at 99.90 and will get a pop up as Install takes more time than usual and installation fails, will removing ~/.nvsdkm help to install successfully?

DRIVE Software 10 installation after shouldn’t have any problem.
Before looking into the booting issue, we need to make sure DRIVE Software 10 installation is really complete.
That’s why I asked you to removing ~/.nvsdkm and do it again.
For the pop-up, you should just click and wait for more time. It happens to me sometimes but doesn’t cause failure.