Drive AGX Tegra A login loop issue

Hello,
We have been doing our development on Drive Xavier AGX (flashed using sdkmanager with Drive software 9.0). We ran into a login loop issue on tegra A which we are not able to resolve. Checked for memory (which is ok). We are able to talk via minicom and also ssh to the tegra but the GUI is an issue which affects any dependent applications to run. Please help us with this - thanks!

Hi adithya.ranga,

Does reflashing the system help? Any suspicious logs on this? Thanks!

Dear adithya.ranga,

Is the symptom of the problem happening after installing any package?
If yes, could you please check if the problem is solved with the following command? Thanks.
sudo dpkg --configure -a

Hi SteveNV and Vickyy,
Yes reflashing is an option but we are holding it as the last resort.
sudo dpkg --configure -a

  • We have tried this with no luck !

Now I see the an issue with the xsession-errors.
libGL error: Unable tot load driver: swrast_dri.so

I am guessing this is causing an issue. Any thoughts ?

Dear adithya.ranga,

I think this is probably a graphic driver issue.
I’m not sure, but would you try to see if there are any changes? Thanks.
sudo update-alternatives --display aarch64-linux-gnu.conf

Hi SteveNV,
There are no alternatives for aarch64-linux-gnu.conf !

Dear adithya.ranga,

Thank you for your update.
I’d like to recommend flash the board as Vick’s comment.

Hi SteveNV,
Thank you for the reply ! We have fixed the issue - it was mostly caused due to LibGL --> links to the .so were overwritten by some of our custom software installations.

For any one having such issues on the Xavier - here are some quick things to check for:

  • See if you can ssh or use minicom to talk to the tegra’s
  • First clear out system cache and free up any memory
  • check ~/.xsession-errors for any errors
  • aarch64-linux-gnu.conf - check for alternatives
  • Last resort - Flash it and watch out for any errors during flashing !