DRIVE Orin DevKit SDK manager flashing failed to version DRIVE OS 6.0.4

The reflash issue was fixed in SDK Manager 1.8.3.
Please download the latest NVIDIA SDK Manager and try it. Thanks.

Upgraded to version 1.8.3 but failed with the same error.


11:18:07 INFO: Flash DRIVE OS - flash: **********************

11:18:07 INFO: Flash DRIVE OS - flash: exec_command: /tmp/

11:18:07 INFO: Flash DRIVE OS - flash: The user `werider' is already a member of `dialout'.

11:18:07 ERROR: Flash DRIVE OS - flash: sed: can't read ./driveinstaller/manifests/install_pdk_config/av_orin_p3710_driveos_linux_tegraA_install_config.json: No such file or directory

11:18:07 INFO: Flash DRIVE OS - flash: [ Component Install Finished with Error ]

11:18:07 INFO: Flash DRIVE OS - flash: [host] [ 12.00 KB used. Disk Avail: 197.55 GB ]

11:18:07 INFO: Flash DRIVE OS - flash: [ NV_DRIVE_FLASH_DRIVE_COMP Install took 0s ]

11:18:07 ERROR: Flash DRIVE OS - flash: command terminated with error

**11:18:07 SUMMARY: Flash DRIVE OS - flash: First Error: No such file or directory**

Full log exported and attached here (54.4 KB)

Thanks for providing the logs. We will check them and update you on this. Thanks.

Please provide the complete sdkmanager logs under ~/.nvsdkm folder for our further analysis.

In the meantime, from the current logs, we could see that your environment is not cleaned before installation. Please

  • uninstall DRIVE 6.0.4 with SDKM first.
  • make sure dpkg -l | grep driveos output is empty.
  • then reinstall DRIVE 6.0.4 with SDKM.

The issue fixed in SDKM client 1.8.3 is that: clicking Retry button now does not remove the target image directory. However, we should still make sure the first installation starts with a clean environment. Thanks.

I tried the Docker Container installation method and I was able to flash to 6.0.4 successfully.

One thing to note is that I had to manually create the sshd config under /etc/ssh/sshd_config and /etc/ssh/sshd_config.d to enable sshd.

Can you please share the procedure to uninstall DRIVEOS 6.0.4 with SDKM? I didn’t find a way in the GUI. I still have another system at version 6.0.3. I can test the SDKM method with that machine.

Is this specific to the target system flashed with the dcoker container? Please also share your commands for manually creating them. Thanks.

Please refer to Repair and Uninstall. Please let us know the result of trying on another system. Thanks.