DRIVE_OS_5.2.0_SDK_Linux_OS_DDPX/DRIVEOS/drive-t186ref-linux not found after installation from SDK Manager

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.0
[*] DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System
[*] Linux

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04
Hi All,
It seems that aforesaid directory is required to cross compile DW samples - per instructions here.

Are we supposed to get this file from DW installation ? I insalled via SDK Manager.


Dear @ai.trucker,
Have you installed DRIVE OS 5.2.0 using sdkmanager? Could you share the directories at ~/nvidia/nvidia_sdk ?

Thanks SivaRamaKrishnaNV.

I used SDK manager for installation.

$ ls !$
ls ~/nvidia/nvidia_sdk
DRIVE_OS_5.2.0_SDK_Linux_OS_DRIVE_AGX_XAVIER DRIVE_Software_10.0_Linux_OS
DRIVE_OS_5.2.6_SDK_Linux_OSWithSamples DRIVE_Software_10.0_Linux_OS_DRIVE_AGX_XAVIER

Dear @ai.trucker,
Could you check for DRIVE_OS_5.2.0_SDK_Linux_OS_DRIVE_AGX_XAVIER/DRIVEOS/drive-t186ref-linux directory?

Dear @ai.trucker,
I meant to use DRIVE_OS_5.2.0_SDK_Linux_OS_DRIVE_AGX_XAVIER/DRIVEOS/drive-t186ref-linux directory path for /path/to/drive-t186ref-linux in the command

Do you mean to say use /my/home/DRIVE_OS_5.2.0_SDK_Linux_OS_DRIVE_AGX_XAVIER/DRIVEOS/drive-t186ref-linux in the compilation command of the drive works samples ?

Dear @ai.trucker,
Please use /my/home/nvidia/nvidia_sdk/ /DRIVE_OS_5.2.0_SDK_Linux_OS_DRIVE_AGX_XAVIER/DRIVEOS/drive-t186ref-linux in DW compilation command. Note /my/home refers to your $HOME directory

I tried to reinstall DOS and DW again from SDK Manager and in the process I might have messed up my previous cuda install (I was trying sudo apt-get purge cuda*) . I do not have /usr/local/cuda* anymore.
When I try to reinstall - I run into error for “sudo apt --fix-broken install”.
Screen Shot 2021-09-21 at 1.23.31 AM

I need to get cuda installation back, as there is no /usr/local/cuda*.

I looked that quite a few old issues related to ‘sudo apt --fix-broken install’ from SDK manager - These links - a) firstb) second c) third - do not seem to address my issue.


Dear @ai.trucker,
What did you see when you run sudo apt --fix-broken install?

Mostly file overwrite issue. I tried moving these files out manually - but it seems to try to write these files twice and wouldn’t like it the second time !


Dear @ai.trucker,
Please check force installation using for each debian package in the error log like sudo dpkg -i --force-overwrite <debian package> . I expect this to install the require versions for the DRIVE OS 5.2.0

There were errors for debs as shown in pic. But it seem to wipe those debs out while exiting. I cannot see any /tmp/apt* directory or any debian package.

Please check force installing the debian packages from the DRIVE OS 5.2.0 download folder manually. Let us know how it goes.

I do not see them in download folder -

~/Downloads/nvidia/sdkm_downloads$ sudo dpkg -i --force-overwrite cuda-nvcc-cross-aarch64-10-2_10.2.311-1_all.deb
dpkg: error: cannot access archive 'cuda-nvcc-cross-aarch64-10-2_10.2.311-1_all.deb': No such file or directory

~/Downloads/nvidia/sdkm_downloads$ ls cuda-nvcc*
ls: cannot access 'cuda-nvcc*': No such file or directory

Dear @ai.trucker,
DRIVE OS 5.2.0 has CUDA 10.2.187. So check installing 10.2.187 debians. Please double check the used sdkm download folder when installing the DRIVE OS 5.2.0.

Is there another way to download ? If you see above msg, I am looking for cuda-nvcc* (for any version) - but I cannot find any, in ~/Downloads/nvidia/sdkm_downloads folder.