Drive PX2 Bootburn / Flashing Failed

I have many issues with flashing my Drive PX2. It took multiple attempts gettings it working with the Driveworks 0.2.1 and now I want to upgrade to Driveworks 0.3 I have not succeeded at all.

I have had no success at all with the DriveInstall program. At least with the minicom / shell flash method I got it working the first time around. This was within Ubuntu 14.04 in a virtual machine.

My general methodology

  1. In the minicom / shell interface;
    tegrarecovery a on
    tegrareset a

  2. In a terminal on the host machine;
    ./bootburn.sh -b p2379c01-t186a -q

The end result;

uccessfully acquired lock over /var/lock/LCK…bootburn
Target ECID(UID)[99:0] BR_CID: 0x81801001642cf8841000000012018200
Detected prod device type
‘/home/dpx/DPX_Install/VibranteSDK/vibrante-t186ref-foundation/utils/scripts/bootburn/…/…/…/firmware/t186/mb1//mb1_recovery_prod.bin’ -> ‘/home/dpx/DPX_Install/VibranteSDK/vibrante-t186ref-foundation/utils/scripts/bootburn/_temp_dump/_temp_dump_M14NmskzKU/rcm-flash/mb1_recovery.bin’
‘/home/dpx/DPX_Install/VibranteSDK/vibrante-t186ref-foundation/utils/scripts/bootburn/…/…/…/firmware/t186/mb1//mb1_prod.bin’ -> ‘/home/dpx/DPX_Install/VibranteSDK/vibrante-t186ref-foundation/utils/scripts/bootburn/_temp_dump/_temp_dump_M14NmskzKU/rcm-flash/mb1.bin’
Sending MB1
Error in execution. Error Code 8. Exiting
Tool OutPut:
RCM version 0X180001
Boot Rom communication completed
Tool OutPut to stderr:
RCM version 0X180001
Boot Rom communication completed

(I get the same result with or without “sudo”)

I manage to proceed no further for now. What is the mysterious Error Code 8? What is going wrong? What should I check?

I also found that I get the same error if I run DriveInstall if I scour through the logs

Dear george.dibben,

According to your logs, you are using virtual machine for HOST PC?
If yes, please don’s use virtual machine for HOST PC.
We don’t support virtual machine for DrivePX2 HOST PC.