DRIVE Software 10 CUDA-X AI Installation Problem

Hardware Platform: DRIVE AGX Pegasus™ Developer Kit
Software Version: DRIVE Software 10
Host Machine Version: native Ubuntu 18.04
SDK Manager Version: Example: 1.4.0.7363
GPU Hardware Architecture: Maxwell (Note: I know I cannot run applications on host machine with this)

Hello,

I am having trouble installing the the CUDA-X AI Host Component. I am relatively new to Linux so I appreciate your help. Thank you!

23:00:52 INFO: TensorRT Cross-Compile for Linux: libnvinfer6-cross-aarch64 is already the newest version (6.3.1-1+cuda10.2).

23:00:52 INFO: TensorRT Cross-Compile for Linux: libnvonnxparsers6-cross-aarch64 is already the newest version (6.3.1-1+cuda10.2).

23:00:52 INFO: TensorRT Cross-Compile for Linux: libnvparsers6-cross-aarch64 is already the newest version (6.3.1-1+cuda10.2).

23:00:52 INFO: TensorRT Cross-Compile for Linux: The following packages were automatically installed and are no longer required:

23:00:52 INFO: TensorRT Cross-Compile for Linux: libnvinfer-consistency6 libnvinfer-safe6

23:00:52 INFO: TensorRT Cross-Compile for Linux: Use ‘sudo apt autoremove’ to remove them.

23:00:52 INFO: TensorRT Cross-Compile for Linux: The following NEW packages will be installed:

23:00:52 INFO: TensorRT Cross-Compile for Linux: libnvinfer-dev-cross-aarch64 libnvinfer-plugin-dev-cross-aarch64

23:00:52 INFO: TensorRT Cross-Compile for Linux: libnvonnxparsers-dev-cross-aarch64 libnvparsers-dev-cross-aarch64

23:00:53 INFO: TensorRT Cross-Compile for Linux: 0 upgraded, 4 newly installed, 0 to remove and 9 not upgraded.

23:00:53 INFO: TensorRT Cross-Compile for Linux: Need to get 0 B/45.2 MB of archives.

23:00:53 INFO: TensorRT Cross-Compile for Linux: After this operation, 239 MB of additional disk space will be used.

23:00:53 INFO: TensorRT Cross-Compile for Linux: Get:1 file:/var/nv-tensorrt-repo-cuda10.2-trt6.3.1.3-d5l-cross-ga-20200724 libnvinfer-dev-cross-aarch64 6.3.1-1+cuda10.2 [43.1 MB]

23:00:53 INFO: TensorRT Cross-Compile for Linux: Get:2 file:/var/nv-tensorrt-repo-cuda10.2-trt6.3.1.3-d5l-cross-ga-20200724 libnvinfer-plugin-dev-cross-aarch64 6.3.1-1+cuda10.2 [1,287 kB]

23:00:53 INFO: TensorRT Cross-Compile for Linux: Get:3 file:/var/nv-tensorrt-repo-cuda10.2-trt6.3.1.3-d5l-cross-ga-20200724 libnvonnxparsers-dev-cross-aarch64 6.3.1-1+cuda10.2 [265 kB]

23:00:53 INFO: TensorRT Cross-Compile for Linux: Get:4 file:/var/nv-tensorrt-repo-cuda10.2-trt6.3.1.3-d5l-cross-ga-20200724 libnvparsers-dev-cross-aarch64 6.3.1-1+cuda10.2 [538 kB]

23:00:54 INFO: TensorRT Cross-Compile for Linux: Selecting previously unselected package libnvinfer-dev-cross-aarch64.

23:00:54 INFO: TensorRT Cross-Compile for Linux: (Reading database … (Reading database … 5% (Reading database … 10% (Reading database … 15% (Reading database … 20% (Reading database … 25% (Reading database … 30% (Reading database … 35% (Reading database … 40% (Reading database … 45% (Reading database … 50% (Reading database … 55% (Reading database … 60% (Reading database … 65% (Reading database … 70% (Reading database … 75% (Reading database … 80% (Reading database … 85% (Reading database … 90% (Reading database … 95% (Reading database … 100% (Reading database … 302099 files and directories currently installed.)

23:00:54 INFO: TensorRT Cross-Compile for Linux: Preparing to unpack …/libnvinfer-dev-cross-aarch64_6.3.1-1+cuda10.2_all.deb …

23:00:54 INFO: TensorRT Cross-Compile for Linux: Unpacking libnvinfer-dev-cross-aarch64 (6.3.1-1+cuda10.2) …

23:00:57 INFO: TensorRT Cross-Compile for Linux: dpkg: error processing archive /var/nv-tensorrt-repo-cuda10.2-trt6.3.1.3-d5l-cross-ga-20200724/./libnvinfer-dev-cross-aarch64_6.3.1-1+cuda10.2_all.deb (–unpack):

23:00:57 INFO: TensorRT Cross-Compile for Linux: trying to overwrite ‘/usr/lib/aarch64-linux-gnu/stubs/libnvinfer.so’, which is also in package libnvinfer5-cross-aarch64 5.1.4-1+cuda10.2

23:00:58 INFO: TensorRT Cross-Compile for Linux: Preparing to unpack …/libnvinfer-plugin-dev-cross-aarch64_6.3.1-1+cuda10.2_all.deb …

23:00:58 INFO: TensorRT Cross-Compile for Linux: Unpacking libnvinfer-plugin-dev-cross-aarch64 (6.3.1-1+cuda10.2) …

23:00:58 INFO: TensorRT Cross-Compile for Linux: dpkg: error processing archive /var/nv-tensorrt-repo-cuda10.2-trt6.3.1.3-d5l-cross-ga-20200724/./libnvinfer-plugin-dev-cross-aarch64_6.3.1-1+cuda10.2_all.deb (–unpack):

23:00:58 INFO: TensorRT Cross-Compile for Linux: trying to overwrite ‘/usr/lib/aarch64-linux-gnu/stubs/libnvinfer_plugin.so’, which is also in package libnvinfer5-cross-aarch64 5.1.4-1+cuda10.2

23:00:58 INFO: TensorRT Cross-Compile for Linux: Preparing to unpack …/libnvonnxparsers-dev-cross-aarch64_6.3.1-1+cuda10.2_all.deb …

23:00:58 INFO: TensorRT Cross-Compile for Linux: Unpacking libnvonnxparsers-dev-cross-aarch64 (6.3.1-1+cuda10.2) …

23:00:58 INFO: TensorRT Cross-Compile for Linux: dpkg: error processing archive /var/nv-tensorrt-repo-cuda10.2-trt6.3.1.3-d5l-cross-ga-20200724/./libnvonnxparsers-dev-cross-aarch64_6.3.1-1+cuda10.2_all.deb (–unpack):

23:00:58 INFO: TensorRT Cross-Compile for Linux: trying to overwrite ‘/usr/lib/aarch64-linux-gnu/stubs/libnvonnxparser.so’, which is also in package libnvinfer5-cross-aarch64 5.1.4-1+cuda10.2

23:00:58 INFO: TensorRT Cross-Compile for Linux: Preparing to unpack …/libnvparsers-dev-cross-aarch64_6.3.1-1+cuda10.2_all.deb …

23:00:58 INFO: TensorRT Cross-Compile for Linux: Unpacking libnvparsers-dev-cross-aarch64 (6.3.1-1+cuda10.2) …

23:00:58 INFO: TensorRT Cross-Compile for Linux: dpkg: error processing archive /var/nv-tensorrt-repo-cuda10.2-trt6.3.1.3-d5l-cross-ga-20200724/./libnvparsers-dev-cross-aarch64_6.3.1-1+cuda10.2_all.deb (–unpack):

23:00:58 INFO: TensorRT Cross-Compile for Linux: trying to overwrite ‘/usr/lib/aarch64-linux-gnu/stubs/libnvparsers.so’, which is also in package libnvinfer5-cross-aarch64 5.1.4-1+cuda10.2

23:00:58 ERROR: TensorRT Cross-Compile for Linux: No apport report written because MaxReports is reached already

23:00:58 INFO: TensorRT Cross-Compile for Linux: Errors were encountered while processing:

23:00:58 INFO: TensorRT Cross-Compile for Linux: /var/nv-tensorrt-repo-cuda10.2-trt6.3.1.3-d5l-cross-ga-20200724/./libnvinfer-dev-cross-aarch64_6.3.1-1+cuda10.2_all.deb

23:00:58 INFO: TensorRT Cross-Compile for Linux: /var/nv-tensorrt-repo-cuda10.2-trt6.3.1.3-d5l-cross-ga-20200724/./libnvinfer-plugin-dev-cross-aarch64_6.3.1-1+cuda10.2_all.deb

23:00:58 INFO: TensorRT Cross-Compile for Linux: /var/nv-tensorrt-repo-cuda10.2-trt6.3.1.3-d5l-cross-ga-20200724/./libnvonnxparsers-dev-cross-aarch64_6.3.1-1+cuda10.2_all.deb

23:00:58 INFO: TensorRT Cross-Compile for Linux: /var/nv-tensorrt-repo-cuda10.2-trt6.3.1.3-d5l-cross-ga-20200724/./libnvparsers-dev-cross-aarch64_6.3.1-1+cuda10.2_all.deb

23:01:00 ERROR: TensorRT Cross-Compile for Linux: E

23:01:00 ERROR: TensorRT Cross-Compile for Linux: : Sub-process /usr/bin/dpkg returned an error code (1)

23:01:00 INFO: TensorRT Cross-Compile for Linux: [ Package Install Finished with Error ]

23:01:00 INFO: TensorRT Cross-Compile for Linux: [host] [ 74.36 MB used. Disk Avail: 144.23 GB ]

23:01:00 INFO: TensorRT Cross-Compile for Linux: [ NV_TENSORRT_HOST_CROSS_LINUX_COMP Install took 13s ]

23:01:00 ERROR: TensorRT Cross-Compile for Linux: [error]: Error when apt install failed; [exec_command]: sudo apt-get update; sleep 0.5; sudo apt-get -y install libnvinfer6-cross-aarch64=6.3* libnvinfer-dev-cross-aarch64=6.3* libnvinfer-plugin6-cross-aarch64=6.3* libnvinfer-plugin-dev-cross-aarch64=6.3* libnvonnxparsers6-cross-aarch64=6.3* libnvonnxparsers-dev-cross-aarch64=6.3* libnvparsers6-cross-aarch64=6.3* libnvparsers-dev-cross-aarch64=6.3* ; [error]: exit status 100; [deb_path]: /home/user1/Downloads/nvidia/sdkm_downloads/nv-tensorrt-repo-ubuntu1804-cuda10.2-trt6.3.1.3-d5l-cross-ga-20200724_1-1_amd64.deb

23:01:00 ERROR: TensorRT Cross-Compile for Linux: command terminated with error

23:01:00 SUMMARY: TensorRT Cross-Compile for Linux: Failed to install debian repository file [host]

Dear @xparr,
Do you plan to use CUDA X on host or target? FYI, The target flashed with DRIVE SW 10 does not support TensorRT 6.3.1

I am planning on using it on host.

Dear @xparr,
CUDA X libs(TRT and other libs) may not work along with DRIVE SW 10 due to supported version mismatch. Could you please uninstall DRIVE SW 10 from host using sdkmanager and check installation of CUDA X?