DriveOS 6.0.4 Flashing Failures

Already mentioned we’ve tried reboots and multiple computers as the host.

As for USB autosuspend, it’s not an issue we’ve seen. It doesn’t seem to be related also based on description of that post. We have no issues with USB once the target is put into debug mode, but normal mode we have no access to ttyACM.

What did you mean debug mode? recovery mode? put it into recovery mode using the recovery button?
I’ll check the no /dev/ttyACMx issue with our team and get back to you.

I think by debug mode I meant recovery mode on the debug USB port.

Hi VickNV,
In my Ubuntu 20.04.5 host, a physical PC, 0955:xxxx is outputed in lsusb command, but still failed to enter recovery mode. I even tried tegrarecovery & tegrareset commands and then run immediately. But still got the same error:

yang@xps:~/nvidia/nvidia_sdk/DRIVE_OS_6.0.4_SDK_Linux_DRIVE_AGX_ORIN_DEVKITS/DRIVEOS/drive-foundation/tools/flashtools/bootburn$ lsusb | grep 0955
Bus 001 Device 011: ID 0955:7045 NVIDIA Corp. 

yang@xps:~/nvidia/nvidia_sdk/DRIVE_OS_6.0.4_SDK_Linux_DRIVE_AGX_ORIN_DEVKITS/DRIVEOS/drive-foundation/tools/flashtools/bootburn$ ./ -b p3710-10-s05 -B qspi
****** Starting bootburn/ ********
Script directory: /home/yang/nvidia/nvidia_sdk/DRIVE_OS_6.0.4_SDK_Linux_DRIVE_AGX_ORIN_DEVKITS/DRIVEOS/drive-foundation/tools/flashtools/bootburn
Parent directory added to path: /home/yang/nvidia/nvidia_sdk/DRIVE_OS_6.0.4_SDK_Linux_DRIVE_AGX_ORIN_DEVKITS/DRIVEOS/drive-foundation/tools/flashtools/bootburn/..
********* Starting t23x bootburn py ********
Bootburn Starting with arguments ['./', '-b', 'p3710-10-s05', '-B', 'qspi']
cwd in setBoardConfigPath :: /home/yang/nvidia/nvidia_sdk/DRIVE_OS_6.0.4_SDK_Linux_DRIVE_AGX_ORIN_DEVKITS/DRIVEOS/drive-foundation/tools/flashtools/bootburn_t23x_py
 trying hardware folder:

cwd in loadBoardGoldenRegsFile :: /home/yang/nvidia/nvidia_sdk/DRIVE_OS_6.0.4_SDK_Linux_DRIVE_AGX_ORIN_DEVKITS/DRIVEOS/drive-foundation/tools/flashtools/bootburn_t23x_py
Default Schema:/home/yang/nvidia/nvidia_sdk/DRIVE_OS_6.0.4_SDK_Linux_DRIVE_AGX_ORIN_DEVKITS/DRIVEOS/drive-foundation/tools/flashtools/bootburn_t23x_py/nv-customer-data-schema-orin.json

Check finished successfully
Done parsing command line

[bootburn]: [getListTargetsInRecovery(3508)] : Bus 001 Device 011: ID 0955:7045 NVIDIA Corp. 
[bootburn]: [CheckRecoveryTargets(3466)] : No recovery-target found; Make sure the target device is connected to the
[bootburn]: [CheckRecoveryTargets(3467)] : host and is in recovery mode. Exiting
command line used was:
['./', '-b', 'p3710-10-s05', '-B', 'qspi']


Exception caught in bootburn 
Traceback (most recent call last):
  File "/home/yang/nvidia/nvidia_sdk/DRIVE_OS_6.0.4_SDK_Linux_DRIVE_AGX_ORIN_DEVKITS/DRIVEOS/drive-foundation/tools/flashtools/bootburn/../bootburn_t23x_py/", line 288, in bootburn
  File "/home/yang/nvidia/nvidia_sdk/DRIVE_OS_6.0.4_SDK_Linux_DRIVE_AGX_ORIN_DEVKITS/DRIVEOS/drive-foundation/tools/flashtools/bootburn/../bootburn_t23x_py/", line 3468, in CheckRecoveryTargets
    AbnormalTermination("ERROR_TARGET_RECOVERY", nverror.NvError_ResourceError)
  File "/home/yang/nvidia/nvidia_sdk/DRIVE_OS_6.0.4_SDK_Linux_DRIVE_AGX_ORIN_DEVKITS/DRIVEOS/drive-foundation/tools/flashtools/bootburn/../bootburn_t23x_py/", line 249, in AbnormalTermination
    raise OSError(errorCode)
OSError: 15
returning to directory /home/yang/nvidia/nvidia_sdk/DRIVE_OS_6.0.4_SDK_Linux_DRIVE_AGX_ORIN_DEVKITS/DRIVEOS/drive-foundation/tools/flashtools/bootburn
Cleaning up ... 
    Cleaning temp dir

@Keelung please create a new topic for your issue and mention this one there if you think related. Thanks.

Hi VickNV,
Solved. It’s my mistake of missing USB-C link. Once USB-C plugged in, 0955:7023 shown in the output of lsusb, then flashing…

Bus 001 Device 013: ID 0955:7023 NVIDIA Corp. 
Bus 001 Device 011: ID 0955:7045 NVIDIA Corp. 

Thanks for letting us know. Let keep using this topic to track the issues of @ibreakthings.


Please try a clean power cycle by unplugging the power supply, waiting for ~30s, and powering back on. This will exclude issues related to entering a fault state with the previous boot. If recovery mode still cannot be entered after this, either through the push button or Aurix, we may need to get the system back to a closer look.

@ibreakthings may I know if clean power cycle help with the missing /dev/ttyACMx issue?

That was one of the first things we had tried. Full power disconnect, wait, reconnect. In fact, it had gone into a vehicle a bit ago which provides multiple instances of no power for extended periods for vehicle work.

Did you mean it is currently set up in a vehicle?


Can you try again on bench not installed in a vehicle?

We will once we have a new unit to replace it.

Did the missing /dev/ttyACMx issue first happen after installing the system in the vehicle?

This I am not really sure. In any case, we can’t really pull it aside until we have one to replace it, which should be soon I’m told.

@ibreakthings As discussed offline, once you’re able to take the unit out, please have it a try on bench and let us know if the issue is still there. Thanks.

@ibreakthings also, I’ll need your to confirm if your hardware team followed DRIVE AGX Orin Mechanical and Installation Guide while they installed the system in the vehicle. Thanks.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

@ibreakthings any update on this?