Driver 520.56.06 crashes after a few minutes of use

I’m currently using the 520.56.06 driver and after a few minutes of use the driver crashes. If I start the nvidia settings, the following message pops up:


ERROR: An internal driver error occurred


(nvidia-settings:8696): GLib-GObject-CRITICAL **: 17:19:31.709: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

** (nvidia-settings:8696): CRITICAL **: 17:19:31.710: ctk_powermode_new: assertion '(ctrl_target != NULL) && (ctrl_target->h != NULL)' failed

My notebook has a Quadro P520 card and the error happens in the offload mode. In the nvidia mode it randomly freezes. What I also noticed is that it does not come back after suspend. The suspend, resume and hibernate scripts are enabled.

inxi -G has the following output

Graphics:
  Device-1: Intel CometLake-U GT2 [UHD Graphics] driver: i915 v: kernel
  Device-2: NVIDIA GP108GLM [Quadro P520] driver: nvidia v: 520.56.06
  Device-3: Chicony HP HD Camera type: USB driver: uvcvideo
  Device-4: Generalplus GENERAL WEBCAM type: USB
    driver: snd-usb-audio,uvcvideo
  Display: wayland server: X.Org v: 22.1.5 with: Xwayland v: 22.1.5
    compositor: gnome-shell v: 43.0 driver: X: loaded: modesetting,nvidia
    unloaded: fbdev,nouveau,vesa dri: iris gpu: i915 resolution:
    1: 3440x1440~60Hz 2: 1440x2560~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 22.2.3

It occurred in X11 as well, for it would not really matter switching from Wayland to it.
The debug report is attached, and I appreciate any help.
nvidia-bug-report.log.gz (72.0 KB)

You’re getting an Xid 79, gpu is list. Since it’s a notebook, it’s most likely broken. Please check your warranty.

Thank you very much for your prompt reply.

After further investigation, I can rule out a hardware defect. I did various tests on Windows, and it worked fine.

Under Linux it now also works, but only in the Nvidia mode with the PowerMizer settings set to “Prefer Maximum Performance”. I assume in the other modes, the card gets too little power and then crashes.
Is there some way to adapt the offload setting? The maximum performance mode is really bothering me, since the fans always run very loudly, which is quite disturbing.

Please check for a bios update, if that doesn’t help try setting kernel parameter
intel_idle.max_cstate=1