Driver compilation on a fresh system

Hi All

I’m trying to compile a driver for a USB3 <–> Ethernet device I have, but I’ve run into some problems.

I have followed the instructions on the vendor web site but when I run ‘sudo make’, I get the following error:

make: *** /lib/modules/3.10.24-g6a2d13a/build: No such file or directory.  Stop.
make: *** [default] Error 2

When I look in the library, the “build” part was in red. Deleting it and making am empty gives me another error, which tells me that I don’t know what I’m doing.

Can anyone help me here?



If you want help you should link to the driver and/or vendor website page.

FYI, assuming “uname -r” shows “3.10.24-g6a2d13a”, just do this:
sudo mkdir /lib/modules/uname -r/build

Might come up with a new error, but the one listed appears to just be a custom build directory missing.

Hi All

Thank you for the replies.

The driver is the AX88179_178A_LINUX_DRIVER_v1.10.0, found on;71;112&PLine=71

(Direct link:

When I create the directory, I just get this error instead:

make -C /lib/modules/3.10.24-g6a2d13a/build SUBDIRS=/home/ubuntu/cudadev/drivers/usb3/AX88179_178A_LINUX_DRIVER_v1.10.0_SOURCE modules
make[1]: Entering directory `/lib/modules/3.10.24-g6a2d13a/build'
make[1]: *** No rule to make target `modules'.  Stop.
make[1]: Leaving directory `/lib/modules/3.10.24-g6a2d13a/build'
make: *** [default] Error 2

I downloaded and compiled this…no errors. Worked first time without warnings. However, it does require kernel source to be in place AND configured to the current kernel, and also possibly requires temporary write permission to /lib/modules/uname -r/build/, sudo should be used.

Is kernel source installed at /usr/src/kernels/uname -r/ ? Did you copy and unzip /proc/config.gz to the kernel dir, make prepare and make modules_prepare (or just make for the whole thing)? Likely this will clear it up.


Linuxdev: This worked perfectly. Thank you!

And no, I had done none of these things. But I learn every day.