Driver doesn't see my Tesla C1060

EDIT: The driver saw my card after I ran nvidia-smi. (Which I tried on a whim.)

I’ve installed CUDA on ubuntu as described in this thread. The driver does not seem to recognize my Tesla card. (No /dev/nvidia* files, running the vectorAdd sample program gives the output “no CUDA-capable device is detected,” and deviceQuery says “cudaGetDeviceCount FAILED CUDA Driver and Runtime version may be mismatched.”)

“lspci -q” reports that there is a Tesla C1060 connected, so I am confused. Any suggestions as to what might have gone wrong?

I thought maybe the C1060 is no longer supported, but it is in the “supported nVidia GPU products page” of the 260.19.26 driver manual.

I have the same problem with Tesla C-2070, driver 270.xx…, SDK 3.2, it works only when X is running.

I have the same problem, it says no CUDA device detected, any suggestions?
I am using Ubuntu 10.10, latest driver form the CUDA developers page

Could you try the following code? After I runned it, the system detect my Tesla.

  • In order to run CUDA applications, the CUDA module must be

    loaded and the entries in /dev created. This may be achieved

    by initializing X Windows, or by creating a script to load the

    kernel module and create the entries.

An example script (to be run at boot time):

#!/bin/bash

/sbin/modprobe nvidia

if [ “$?” -eq 0 ]; then

Count the number of NVIDIA controllers found.

N3D=/sbin/lspci | grep -i NVIDIA | grep "3D controller" | wc -l

NVGA=`/sbin/lspci | grep -i NVIDIA | grep “VGA compatible controller” |

wc -l`

N=expr $N3D + $NVGA - 1

for i in seq 0 $N; do

mknod -m 666 /dev/nvidia$i c 195 $i;

done

mknod -m 666 /dev/nvidiactl c 195 255

else

exit 1

fi

The problem is in some permissions. If you login as root, you may run SDK examples in console without a running X despite there is still no one /dev/nvidia… file.
It works for both sudo and su.

Thank you for your replay.

Configs: Ubuntu 11.04, CUDA 4.0, Tesla C1060.

I followed this: http://forums.nvidia.com/index.php?showtopic=198030

and added the above script to run at start up.

I’ve been trying to compile “template” from the SDK, I am getting this error:

template.cu(60): cudaSafeCall() Runtime API error 3: initialization error.

On my other machine with GeForce 460 it is running smoothly. Any ideas?

Thanks in advance.