Driver installation problems on Debian 10 and Quadro p600

I have installed Debian 10.2.0 on a HP ZBook 15v G5 (Intel i7-8750H) with a Quadro p600 GPU.
To boot the sistem I need to add ‘noveau.modeset=0’ to the boot parameters.

The OS recongnize the two video controller but once a extarnel monitor is connected it doesn’t receive any signal.

I have installed the Bumblebee and the Nvidia driver with the command:

sudo apt-get install bumblebee-nvidia primus libgl1-nvidia-glx

After the installation I still need the ‘noveau.modeset=0’ boot parameter to start the OS.

The OS recongnize the two video controller but still once a extarnel monitor is connected it is not recongnize and doesn’t receive any signal.

$ lspci -k | grep -EA3 "VGA|3D|Display"
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
        Subsystem: Hewlett-Packard Company UHD Graphics 630 (Mobile)
        Kernel driver in use: i915
        Kernel modules: i915
--
01:00.0 VGA compatible controller: NVIDIA Corporation GP107GLM [Quadro P600 Mobile] (rev a1)
        Subsystem: Hewlett-Packard Company GP107GLM [Quadro P600 Mobile]
        Kernel driver in use: nvidia
        Kernel modules: nvidia
$ xrandr 
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1920x1080     60.06*+  40.04  
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)

The Bumblebee service is running.
The nvidia-settings fails to start.

I really don’t know how to get it running.
Thank you.
nividia_report.txt.gz (1 MB)

@alberto.arnolfi

  1. First of all, disable hybrid graphics from the system BIOS and select discrete graphics option. This shall make Quadro p600 as sole GPU on your Zbook, thus making your configuration far simpler and robust. Hybrid Nvidia graphics is known to be difficult to configure under Linux.
  2. Uninstall all of the older drivers that you have installed as mentioned in your post.
  3. Follow the driver installation steps as mentioned here: https://wiki.debian.org/NvidiaGraphicsDrivers
  4. You may have to manually select the external monitor option by going to Gnome Settings

P.S. I have the exact same model.

Thanks @sarthakdae,
following your istructions I resolved the problem: now with the discrete graphics option enabled I can use my external monitor.

Dear @sarthakdae,
after I have disable hybrid graphics I have made some test and found some more issues:

  1. With the nouveau driver I can use an external monitor but I can’t control the brightinss level that always stays at the maximum.

  2. Once I haved installed the nvidia driver (following: https://wiki.debian.org/NvidiaGraphicsDrivers ) to boot the os I still need to add ‘nouveau.modeset=0’ to the kernel parameters.
    Now I can correctly control the brightiness level but the desktop graphics appers much larger then before as if the actual number of pixels isn’t correctly managed.

Have you had the some issue with the nvidia driver?

I attach two screenshots to show how the Nvidia driver has problem to manage the screen resolution.

  • Screenshot_noveau.png, display with noveau driver
  • Screenshot_nvidia.png, display with Nvidia driver

As you can see with the Nvidia driver everythings appears much larger.

Anyone can help me?


@alberto.arnolfi

I have not encountered the issue as shown in your screenshots. However, I also have not provided ‘nouveau.modeset=0’ in the boot parameters. AFAIK this step is needed only when nvidia driver is installed manually.