Driver Issues, Linux Mint 20.1, NVIDIA 2060/Ryzen 9 4900 Combo

My NVIDIA card is listed as unclaimed in lshw report, it seems to not recognize the driver that I installed through ubuntu-drivers, and I cannot seem to get it to work at all. nvidia-smi gives me a driver communication error. I have tried many of the suggestions I have seen on here, but none of them seem to have fixed this. I have ubuntu-drivers 8.6.5. Not really too sure what do do. Please Help!

nvidia-bug-report.log.gz (430.0 KB)

I read your bug report.

  • Never use the graphics PPA. its a trap. The libs are usually out of sync.
  • nVidia doesnt use the MESA Stack , ever at all for desktop graphics.
  • note:Im not saying lib-mesa.
    1. Always kill the xserver before installing nvidia or purging anything.
  • This will prevent symlinking issues and or humpty dumptying your Linux OS.
    1. ALWAYS completely purge nvidia* libnvidia on every kernel / driver change.
  • Why? Example: Location and Size of vulkan Shader Cache in 460. New driver will use old driver config.
    1. Run pciutils and fwupd before and after every driver, firmware and kernel change
  • Think of dkms as to install the nVidia driver for the kernels your not using;
  • not the kernel your about to use.
  • This is totally wrong but completely right. Learn the links below as to know why.
    1. blacklist and 5. modeset and 6. set kernel parameters and 7. set the correct bios settings.
  • Once you wrap your head around it its super easy to get outstanding performance.
  • Read the Official WhitePapers.
  • 80 percent of the answers are below. 15 percent are at kernel.org and the other 5 percent are on GitHub.

https://www.nvidia.com/Download/driverResults.aspx/170134/en-us
http://us.download.nvidia.com/XFree86/Linux-x86_64/460.39/README/index.html
*
https://wiki.archlinux.org/index.php/NVIDIA
https://wiki.archlinux.org/index.php/NVIDIA/Tips_and_tricks
https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting
https://wiki.archlinux.org/index.php/NVIDIA_Optimus
https://wiki.archlinux.org/index.php/PRIME

Good Luck.

1 Like

Never listen to murphy, it’s a troll ;)

This looks like you added the kernel ppa (not recommended) and you got upgraded to kernel 5.11.0 while having driver 460.32.03 installed, which is incompatible. You could upgrade the driver to 460.39 but you should rather remove the kernel ppa and return to the stock 5.8 kernel. Your system should run fine with it.

1 Like

Okay, thank you for your responses. I don’t have a 5.8 kernel version installed right now. The stock kernel on my distribution is 5.4.0-65 at the moment, and I’ve got a 5.4.0-26 installed as well from when I first put this OS on my laptop. I wouldn’t mind using the 460.39 version, but I wasn’t able to get it working. It said that nvidia-drm and I think something else too failed to install. This is probably because I didn’t properly uninstall the driver that I had installed beforehand, but I’m not certain. I’m going to boot a 5.8 kernel and see if I’ll be able to use my GPU with that. I’m wondering if installing 3rd-party mesa drivers for my iGPU is the reason why I’m having issues now. This started when I switched a setting in ‘nvidia-settings’ from “nvidia” to "on-demand’, and I’m wondering if the reason it broke things is because the nvidia driver didn’t know how to deal with the stuff from that ppa. I’m going to try purging that ppa and then reinstalling the nvidia driver if things still aren’t working with that 5.8 kernel. So I want to ask this: if I wanted to completely uninstall the nvidia driver I’ve got now, would something like ‘sudo apt remove --purge nvidia* libnvidia*’ be sufficient?

You should simply upgrade your hwe to get kernel 5.8 and a recent xorg:
https://wiki.ubuntu.com/Kernel/LTSEnablementStack

1 Like

I guess you added the mesa ppa, this shouldn’t have any influence on the nvidia driver working. How did you get the 5.11 kernel? Please check the ppas you have installed in Software&Updates.

1 Like

I do have a kernel ppa, the guy that made it called it"xanmod". I got it to test some WINE setting that wasn’t available using regular kernels. I don’t think I really need it. It was working fine for a while with my GPU, but I’m not particularly attached to it. I’m going to install “linux-generic-hwe-20.04” through apt and see what happens.

Okay I have kernel 5.8.0-43-generic installed, from ubuntu’s 20.04 hwe package. However my video card is still listed as unclaimed when I run lshw. My OS’s driver manager thinks that NVIDIA 460.32.03 is running. ‘prime-select query’ outputs ‘nvidia’. What should I do now?

Also, I uninstalled all of the modified kernels I got through the xanmod ppa.

Please run
sudo dkms install nvidia/460.32.03
reboot, then create a new nvidia-bug-report.log

1 Like

Here is the bug report after running ‘sudo dkms install nvidia/460.32.03’ command and rebooting.nvidia-bug-report.log.gz (453.0 KB)

Okay, I think I have fixed it. Nvidia did not like those 3rd party mesa drivers from oibaf’s ppa. I ppa-purged his ppa, and then reinstalled the packages that were removed because they had their dependencies replaced with those 3rd-party drivers, reinstalled 460.32.03, and it’s working at the moment. Let’s see if it keeps working after I reboot = ).

Yep, it’s working now. Thanks for the help guys = )

Frankly I’m not sure what ended up fixing it. I don’t think I had the oibaf ppa on my testing partition, which had a fresh install of mint 20.1, and I had similar issues getting either version of the 460 driver to work there as well. ¯\_(ツ)_/¯