Driver Issues?

Ubuntu 16.04, Driver 396.51, V100 (Azure VM with XFCE 4.12 desktop)

with GST_DEBUG=2, sample app produces the following messages:

Now playing: …/…/…/samples/streams/sample_720p.h264
0:00:00.814865219 26413 0x1c2ac10 ERROR egladaption ext/eglgles/gstegladaptation_egl.c:144:gst_egl_adaptation_init_display: Could not get EGL display connection

0:00:00.814906717 26413 0x1c2ac10 ERROR egladaption ext/eglgles/gstegladaptation_egl.c:185:gst_egl_adaptation_init_display: Couldn’t setup window/surface from handle

0:00:00.814912617 26413 0x1c2ac10 ERROR nveglglessink ext/eglgles/gsteglglessink.c:526:egl_init: Couldn’t init EGL display

0:00:00.814926116 26413 0x1c2ac10 ERROR nveglglessink ext/eglgles/gsteglglessink.c:552:egl_init: Failed to perform EGL init

Anything I can do to make this work in this environment?


Do you have x11?
Here we did not get Display(“Could not get EGL display connection”).

wayne zhu

Hi fierval,
Have you succeed to install GPU graphic driver?
Our eglglessink is based on X11.

wayne zhu

I suspect that it’s not going to work for a remote display, which is my case. I am working on a virtual machine in Azure cloud.

I tried Deepstream 1.5 and again everything worked great until it came to actual display. It was a remote display issue with glut in that case.

Hi Fierval,

Yes, you can’t use remote display for render, you will not get EGL_Display in this case.

wayne zhu

I’m trying out the DeepStream 2.0 Early access package, running it on an instance of the Google Cloud Platform. Running the samples is not working out correctly.

Is it possible to try out the DeepStream samples on a cloud instance?


AFAIK, Tesla & Jetson are the only types of supported GPUs. Also you cannot have a remote display, so playing the videos won’t work. (See above)

Thanks. I was indeed using a Google Cloud instance with a Tesla GPU. But the problem was the remote display.
I was later able to work around this, by redirecting the output to a file on the cloud instance, and then view the file after downloading it locally.

Good evening,
I would like to include myself in the discussion, as I am experiencing the same difficulties but in a slightly different configuration.
in the laboratory we have 2 servers equipped with 2 TESLA P4 CPUs, and we also access the servers remotely.
Unfortunately, following the official guides we can not see anything.
I’m asking for a kind support.