Driver not loading on boot, SecureBoot disabled, installed with runfile

Hi all,

I am experiencing problems with the drivers not being loaded upon boot.

This topic has been discussed a few times already, for example, here:

The proposed solutions do not apply to me because:

  1. I am using a headless ubuntu server, without integrated graphics
  2. I am not using SecureBoot, or at least the kernel is not aware of it

I have installed the drivers + CUDA using the runfile as it was easy to choose the platform and all that. If we look in the bug report, we can see that the installer correctly detected that the drivers already existed. However, I continued with the installation as that was the only way to get the drivers loaded.

We can then see that it then loads the drivers, although they are not signed. I think this is the problem: even though SecureBoot is disabled*, it still won’t load the drivers at boot (this askUbuntu answer says the same).

Though I’m not sure how “disabled” SecureBoot is, since in dmesg I have secureboot: Secure boot could not be determined (mode 0). According to this Reddit comment, it is disabled, since I have a zero when running od -An -t u1 /sys/firmware/efi/efivars/BootCurrent-8be4df61-93ca-11d2-aa0d-00e098032b8c (Note that I don’t have any .../efivars/SecureBoot... files).

So, how could I overcome this problem and have the NVidia drivers be loaded on boot? I’m happy if it involves manually loading them in a script.

Many thanks,
Ciprian

Edit: added bug report
nvidia-bug-report.log (357.0 KB)