Drivers/Ubuntu version mismatch

Weird thing I noticed:

Ubuntu 18.04 LTS has only 390 versioned Nvidia drivers available (in Software & Updates).

Ubuntu 19.04 has 418 Nvidia drivers available (recommended for Isaac), but of course Isaac SDK doesn’t work on this OS :(.

Is there reason why this SDK won’t work on 19.04 Ubuntu?

To get Isaac SDK and Sim to work, you can install 418 Nvidia drivers on Ubuntu 18.04. Don’t look for the driver in Software & Updates. Instead execute the following commands in your Terminal:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-driver-418

Thank you for helpful answer!

No problem! It’s my pleasure. I completed the environment setup for Isaac Sim and SDK last week and was able to get everything to work. If you run into any other problems, let me know. I am happy to help.