Driveworks Radar Replay Port not outputting correct port

I have currently using Driveworks 1.2 samples of radar replay. Using the pre-compiled examples, I am trying to get the radar example to work through ethernet.

I am using this command line

/usr/local/driveworks/bin/./sample_radar_replay --protocol=radar.socket --params=device=DELPHI_ESR2_5,ip=**********,port=5555,file=/usr/local/driveworks/data/samples/sensors/radar/delphi/radar_0.bin

It gives me this error.

TCP connection failed ip *********, port 45845

I specified port 5555 but returns 45845 for some reason. If I specify port 1, I get port=1283 as the error result. Am I passing the port wrong? I know it’s really simple, but the output error log doesn’t make any sense. I can ping the IP address correctly and see that the port is open so I know it exists. Is there a fix to this bug?


Dear kalani,

There are two cases for the example.

  1. Display live radar point clouds
./sample_radar_replay --protocol=radar.socket --params=device=[type of device],ip=[radar IP address],port=[radar port]
  1. Display recorded Radar point clouds
./sample_radar_replay --file=[radar bin file]

You tried to do two things at once.
Could you please try to run with the following command?
$sudo ./sample_radar_replay --protocol=radar.socket --params=device=DELPHI_ESR2_5,ip=**********,port=5555

Hi Steve,

I tried the example with sudo and without the recorded radar point clouds, but I still get a port error. It still looks for port 45845 instead of port 5555. I tried with random bigger numbers such as 215555 and got port 912 instead. What might be possibly going on?


Dear kalani,

Could you please try to re-run the sample with below command?

./sample_radar_replay --protocol=radar.socket --params=ip=x.x.x.x,port=5555,device=DELPHI_ESR2_5

And can I know about DELPHI_ESR2_5? Is it 12VDC?