Ds-example in batchprocessing not working

• Hardware Platform (Jetson / GPU) GPU RTX 2060
• DeepStream Version 5.0
• TensorRT Version 7.1
• NVIDIA GPU Driver Version (valid for GPU only) 450

I have added dsexample in the pipeline between nvvidconv and nvosd
and its working except
when I tried access 2 videos its giving information of 1 batch at a time in gst_dsexample_transform_ip function

‘’’
static GstFlowReturn
gst_dsexample_transform_ip (GstBaseTransform * btrans, GstBuffer * inbuf)
{
GstDsExample *dsexample = GST_DSEXAMPLE (btrans);
GstMapInfo in_map_info;
GstFlowReturn flow_ret = GST_FLOW_ERROR;
gdouble scale_ratio = 1.0;
DsExampleOutput *output;

NvBufSurface *surface = NULL;
NvDsBatchMeta *batch_meta = NULL;
NvDsFrameMeta *frame_meta = NULL;
NvDsMetaList * l_frame = NULL;
guint i = 0;
batch_meta = gst_buffer_get_nvds_batch_meta (inbuf);
std::cout<<"numbatch inside gst:"<<batch_meta->num_frames_in_batch<<"\n";

‘’’

output is
numbatch inside gst:1

Similar to this my source_id is always 0 even if I have 2 inputs!!!

My pipeline is queue1, pgie, queue2,nvtracker, queue3, tiler, queue4,
nvvidconv, queue5,dsexample, queue6, nvosd, queue7, sink,

please respond

Hi Please someone respond

Can you try with latest DS 6.0?

Is it wont work with 5.0 or 5.1?

Because upgradation will take some time and we need to deploy the device soon
with 5.1 in jetson nano

Mine is similar to this But couldnt understand how she solved it!!

please find attached code
deepstream_test3_app.c (24.0 KB)
gstdsexample.cpp (34.2 KB)

Your pipeline shows you put dsexample after nvmultistreamtiler. The Gst-nvmultistreamtiler plugin composites a 2D tile from batched buffers. Gst-nvmultistreamtiler — DeepStream 6.0 Release documentation After nvmultistreamtiler, the batch is a one frame batch. So it is correct to see batch size is 1.

Thank you its working