DSI enabling via software

I’m working on jetson TX1 board and have to get a screen working using MIPI DSI. We were able to get one of the displays to work with a HDMI cable. Now, we have to get another screen to display using DSI. We have enabled DSI related configurations in the kernel, but still no success. We looked at various forums pertaining to TK1 and TX1, but none of them mention about the procedure on how to enable DSI in the software.

Thanks in advance.

I’ve never set up DSI, so I can’t offer any advice specific to this. Assuming the device has become available, I’d assume the next step would require proper configuration of the X11 server. Understand that the EDID data line of HDMI provides information to the video system in a standard format used for automated configuration…your DSI must either provide EDID data this way as well, or else the configuration would require manually adding the information to the “/etc/xorg.conf” file by hand (an exception would be if the default mode just happens to work with the particular display). Does the DSI have EDID (I am not familiar with DSI wiring)?

Incidentally, packages “read-edid” and “edid-decode” may be of use in showing what the system sees:

sudo get-edid | parse-edid
sudo get-edid | edid-decode

Additionally, raw EDID data can be seen in a TX1 for the HDMI via:

# See edid files:
find /sys/kernel/debug -name 'edid'
# See content of edid files:
sudo cat `find /sys/kernel/debug -name 'edid'`

Note that for a default JTX1 with just a single HDMI display the file path in “/sys” is:


The “tegradc.1” might change depending on display when there is more than one display.

Thanks linuxdev for replying.
When I executed

sudo cat `find /sys/kernel/debug -name 'edid'`

it says

No Such file or directory

Which L4T release are you using? See “head -n 1 /etc/nv_tegra_release”.

Assuming you have a version of L4T which supports report of EDID in “/sys” this would indicate that you have no EDID-capable video device (which in turn would imply no automatic configuration is possible…only a lucky default configuration or manual configuration would work).

I executed the command and here’s what I got this

# R23 (release), REVISION: 1.1, GCID: 6258892, BOARD: t210ref, EABI: hard, DATE: Mon Nov 9 21:23:18 UTC 2015

I don’t actually know if R23.1 supports EDID through “/sys”, so perhaps EDID still works. While your HDMI monitor is connected run the above mentioned get-edid commands. Add your DSI, and see if this changes.

Do you need R23.1? If not you may want to just move to R24.2 before further testing.

Hi guys,

Can you help me on DSI Driver on Tegra K1? I have tried to integrate AUO MIPI LCD B101UAN01.7 into our customized system based on TEGRA K1 CPU. So far we have checked everything around connection to CPU and its schematics. It seems everything is correct. For the LCD, it has ORISE TECH OCT3108B-HV161 MIPI IC and it is different than usual MIPI LCDs. However, I have contacted with the technical team of AUO and they said this lcd passive type of MIPI LCD. There is no need of initiating code and special sequence. I have enabled TK1 DSI configuration on kernel and changed the values in many different ways according to the Technical Reference Manual of TK1. There is no success at all.

I hope that you can tell us what we do wrong.



I have not set up DSI before, so I have no useful knowledge on the topic. Typically you’d be looking for dmesg output and serial console boot log output to see what is or isn’t seen for your hardware…but I have no way of helping beyond that.