dts consult about a carrier board without the HDMI circuit

Dear Sir,

Environment : Jetpack 3.3
U-boot/Kernel : tegra-l4t-r28.2.1

We have design a carrier board without the HDMI circuit, but it always print i2c transfer timed out after booting to kernel that’s similar this post
https://devtalk.nvidia.com/default/topic/1024794/jetson-tx2/tx2-hdmi-disable-i2c-transfer-timed-out-addr-0x50/post/5212928/#5212928

[  154.957178] tegra-i2c 3190000.i2c: rx dma timeout txlen:28 rxlen:128
[  154.963659] tegra-i2c 3190000.i2c: --- register dump for debugging ----
[  154.970596] tegra-i2c 3190000.i2c: I2C_CNFG - 0x22c00
[  154.975831] tegra-i2c 3190000.i2c: I2C_PACKET_TRANSFER_STATUS - 0x10001
[  154.982671] tegra-i2c 3190000.i2c: I2C_FIFO_CONTROL - 0x1c
[  154.988318] tegra-i2c 3190000.i2c: I2C_FIFO_STATUS - 0x800040
[  154.994155] tegra-i2c 3190000.i2c: I2C_INT_MASK - 0x6c
[  154.999405] tegra-i2c 3190000.i2c: I2C_INT_STATUS - 0x2
[  155.004731] tegra-i2c 3190000.i2c: i2c transfer timed out addr: 0x50

I’ve tried to follow those advice to fixed this problem, but there seems on one could fixed.
Util I tried to follow GimpMaster’s steps to disable HDMI in this post
https://devtalk.nvidia.com/default/topic/1023861/

  1. Modify tegra186-quill-p3310-1000-a00-00-base.dts
  2. Change the following dts path /host1x/sor1/ parameter hdmi-display status = “disabled”

The “i2c transfer timed out” is disappear, but there is another problem about tegra_dc_shutdown while poweroff/reboot like this post
https://devtalk.nvidia.com/default/topic/1036641/crash-observed-with-reboot-force-recovery-command-with-rel-28-2/?offset=9

[  272.834796] ------------[ cut here ]------------
[  272.839407] WARNING: at ffffffc000412600 [verbose debug info unavailable]
[  272.846185] Modules linked in:
[  272.849245]
[  272.850738] CPU: 0 PID: 1 Comm: systemd-shutdow Not tainted 4.4.38+ #4
[  272.857256] Hardware name: quill (DT)
[  272.860915] task: ffffffc1ece38000 ti: ffffffc1ecdcc000 task.ti: ffffffc1ecdcc000
[  272.868393] PC is at tegra_dc_shutdown+0x38/0x98
[  272.873009] LR is at platform_drv_shutdown+0x20/0x30

I though that might not a best approach which to disable relate function of HDMI…
Dose anyone could give me any suggest to fixed this one??

Hi,

Please also disable the 3 “nvdisplay” nodes in device tree.

Dear WayneWWW,

I’ve tried to disable the 3 “nvdisplay” in tegra186-quill-common.dtsi,
then it seems be fixed now, Many Thanks!!

Best Regards,
MOMO Chen

Sorry for a record,

There’re the 2 “nvdisplay” in tegra186-quill-p3310-1000-a00-00-base.dts already,
It just need to add the other “nvdisplay” and disable it.

Best Regards,
MOMO Chen