Dual GPU + Triple Monitors - Horizontal Screen Split

Hi,
I have a weird issue with my monitor setup: All displays, besides the primary, have a weird offset. They are horizontally split, and the top of my screen is in the lower part of my monitor while the lower part is in the upper part. See here(https://imgur.com/a/OmSrAo6).

My hardware configuration:

  • 2x NVIDIA GeForce RTX 2080 Ti Rev. A
  • 3x Seasonic ELite 1440p Monitors (all connected to the first GPU)

My Software Setup:

  • OS: Arch Linux
  • WM: Qtile
  • Driver: Nvidia-dkms
  • Kernel: 5.10.6.arch1-1

This issue occurs only with the Nvidia (regardless if nvidia or nvidia-dkms) driver. While running the stock driver, everything shows up fine.

I suspected an issue in my Xorg configurations (see here), but neither nvidia-settings did the trick, nor another distro (Linux Mint). As soon as I installed the Nvidia driver (v460), the same issue occurs. So the problem seems to be specific to my setup. It’s either the dual GPU setup or the 2080 Ti causing problems. I have a second system with a 2080 Super, all three monitors attached via DP to it, and there are no issues so far.

Best,
Sandro

In order to rule out a problem with the first gpu by itself, did you already try to connect the monitors to the second gpu?

1 Like

Hi generix,
Yes, I tried the second card, and the issue persists. In addition to that, I put each display cable separately to the GPU to make sure it’s not a weird port problem. However, a single display shows up fine. It somehow makes sense because it becomes the primary monitor automatically. If I add a second monitor, the problem appears instantly.
So, I don’t think it’s neither the GPU nor a port issue, but maybe I’m wrong here. It’s worth to mention that I use the following ports:
DP, USB-C, HDMI
Each cable goes to the HDMI port on a monitor.

Another thing speaking against faulty hardware is the fact that everything works fine with the stock drivers. The problem appears only with the Nvidia driver installed.

Did you check with an 450 driver?

Unfortunately, I can’t. The nvidia-450xx-dkms package doesn’t exist in the AUR anymore. I tried to install the nvidia-440xx-dkms package, but it doesn’t compile with kernel version 5.9 and above.