Dual monitor setup issue, Fedora 19, driver 325.15


I recently upgraded from Fedora 18 to 19 and now it appears that I cannot get my displays set up the way I used to without manually running nvidia-settings.

To describe my setup:
I have a Dell 2408 1920x1200 display on the right, connected via DVI to a GT 610.
On the left is a Dell U2410 1920x1200 display, connected via HDMI to the same GT610.

Under Fedora 18 (I don’t remember the Xorg or akmod NVIDIA versions), the right panel was “primary” and contained my Gnome3-in-fallback menu and window bars, and I could scroll left across the screen from the 2408 to the U2410.

Now, under Fedora 19, the Dell 2408 (on the right), is still my primary display, but when I try to scroll left onto the U2410, I hit the edge of the screen. X thinks the monitor physically on the left is on the right, and I have to scroll my mouse off the right edge of my primary display to get to it.

If I run nvidia-settings and choose Position:RightOf for the 2408, then things are good for that session only, despite having saved the configuration produced by nvidia-settings to /etc/X11/xorg.conf.

Here is my xorg.conf produced by nvidia-xconfig and then updated by nvidia-settings:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 325.15  (buildmeister@swio-display-x64-rhel04-03)  Wed Jul 31 19:04:13 PDT 2013

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 325.15  (buildmeister@swio-display-x64-rhel04-03)  Wed Jul 31 19:04:27 PDT 2013

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL 2408WFP"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 610"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DVI-I-1: nvidia-auto-select +1920+0, HDMI-0: nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24

I’ve tried inserting MetaModeOrientation (and TwinViewOrientation just for the sake of it) with “DFP-0 RightOf DFP-1”, in the Screen section, tried it with DFP-1 LeftOf DFP-0, tried reversing DFP-0 and DFP-1 around, all to no avail. Running nvidia-settings and writing out the /etc/X11/xorg.conf used to “just work”, but that no longer is the case.

Anything completely obvious that I am missing?

Thank you.

This behavior is typical of certain desktop environments overriding the display configuration in xorg.conf with what they think is the “correct” layout. Since you’re running GNOME, can you please try using GNOME’s display configuration dialog to rearrange the displays instead of using nvidia-settings?

That… worked. You have no idea how absolutely frustrated I am that it worked. I’ve never had to use the GNOME “Display” tool previously because it just obeyed the default X configuration as built by nvidia-settings. It is annoying that the gdm login screen exhibits the undesired behavior but, now that I know GNOME thinks it knows better than what I want, I could correct it but I think it’s time to give up on GNOME3 and go back to Xfce. And sure enough, during my troubleshooting this morning, lightdm and Xfce are both smart enough to not try and xrandr their way around the xorg.conf so things work as expected.

Thank you for the suggestion. It saved me agonizing hours of dconf-editoring my way through GNOME3’s settings.