Dusty-nv inference, how to skip frame in mp4?

Hi,

If I used dusty-nv object detection (with many addon code), the web cam can skip frame and the display is smooth.
But if I use mp4 instead, the output video is slow because it captures every frame. How can I skip the mp4 frame?

Plan B is to create a mp4 with lower fps.

Thx

Hi,

There is a framerate option in the video source of jetson-inference.
Please give it a check.

Thanks.

I have tried
video-viewer --framerate=1 1.mp4
video-viewer --frameRate=1 1.mp4
and
video-viewer --input-rate=1 --output-rate=1 1.mp4
All do not work…

I can see in thermal
–height: 1080
–frameRate: 1.000000

But the video is smooth, does not feel like 1fps. Thx

Don’t worry, I use AGX instead of Nano. Problem solved.
Cheers.