Dynamically Changes in the dtb orin nx

I want to enable Uart-B

serial@3110000 {
compatible = “nvidia,tegra194-hsuart”;
iommus = <0x06 0x04>;
dma-coherent;
reg = <0x00 0x3110000 0x00 0x10000>;
reg-shift = <0x02>;
interrupts = <0x00 0x71 0x04>;
nvidia,memory-clients = <0x0e>;
dmas = <0x3f 0x09 0x3f 0x09>;
dma-names = “rx\0tx”;
clocks = <0x02 0x9c 0x02 0x66>;
clock-names = “serial\0parent”;
resets = <0x02 0x65>;
reset-names = “serial”;
status = “disabled”;
phandle = <0x2e3>;

I am using Custom Carrier Board with Orin NX Module.
so how do i make changes in the device tree dtb file dynamically . As i don’t want to reflash my orin nx module again and again.

Hi afzal.hasan,

What’s your Jetpack version in use?
You could decompile the /boot/dtb/kernel_XXXX.dtb and modify the dts file for the custom change.
Then, assemble it back to dtb and reboot the board to apply the change.

I am using L4T Version 35.2.1

okay, please just using dtc command to decompile/assemble the dtb file under /boot/dtb.
You can modify the status for serial@3110000 to okay and check the dmesg.

I am using Custom Carrier Board which is having two uart channels Uart 0 and Uart 1. So uart 1 is enabled but uart0 i.e serial@3110000 which is inside the L4T 35.2.1/Bootloader inside the tegra234-p3767-0000-p3509-a02.dtb is not enabled so do i make changes inside the given path and reboot the device so is this steps works ?

Sorry that I’m not clear about what do you mean here.

After modifying the device tree, you should reboot the board to apply the change.
The modified dtb will be loaded during boot up.

Please share the “kernel_XXX.dtb” under “/boot/dtb/” and also the full dmesg for further check.

Thanks for your help, I am able to solve this issue