E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution)

When I give command sudo apt-get upgrade
The following packages have unmet dependencies:
cuda-drivers-510 : Depends: libnvidia-compute-510 (>= 510.47.03) but it is not installed
Depends: libnvidia-gl-510 (>= 510.47.03) but it is not installed
libnvidia-decode-510 : Depends: libnvidia-compute-510 (= 510.47.03-0ubuntu1) but it is not installed
nvidia-compute-utils-510 : Depends: libnvidia-compute-510 but it is not installed
nvidia-driver-510 : Depends: libnvidia-gl-510 (= 510.47.03-0ubuntu1) but it is not installed
Depends: libnvidia-compute-510 (= 510.47.03-0ubuntu1) but it is not installed
nvidia-utils-510 : Depends: libnvidia-compute-510 but it is not installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

When I try to solve using apt --fix broken install or other ways :
Get:1 file:/var/cuda-repo-ubuntu1804-11-6-local libnvidia-compute-510 510.47.03-0ubuntu1 [16.8 MB]
Get:2 file:/var/cuda-repo-ubuntu1804-11-6-local libnvidia-gl-510 510.47.03-0ubuntu1 [139 MB]
debconf: delaying package configuration, since apt-utils is not installed
(Reading database … 212248 files and directories currently installed.)
Preparing to unpack …/libnvidia-compute-510_510.47.03-0ubuntu1_arm64.deb …
Unpacking libnvidia-compute-510:arm64 (510.47.03-0ubuntu1) …
dpkg: error processing archive /var/cuda-repo-ubuntu1804-11-6-local/./libnvidia-compute-510_510.47.03-0ubuntu1_arm64.deb (–unpack):
trying to overwrite ‘/usr/lib/aarch64-linux-gnu/libcuda.so’, which is also in package nvidia-l4t-cuda 32.7.1-20220219090432
Preparing to unpack …/libnvidia-gl-510_510.47.03-0ubuntu1_arm64.deb …
dpkg-query: no packages found matching libnvidia-gl-450
Unpacking libnvidia-gl-510:arm64 (510.47.03-0ubuntu1) …
dpkg: error processing archive /var/cuda-repo-ubuntu1804-11-6-local/./libnvidia-gl-510_510.47.03-0ubuntu1_arm64.deb (–unpack):
trying to overwrite ‘/usr/share/glvnd/egl_vendor.d/10_nvidia.json’, which is also in package nvidia-l4t-3d-core 32.7.1-20220219090432
Errors were encountered while processing:
/var/cuda-repo-ubuntu1804-11-6-local/./libnvidia-compute-510_510.47.03-0ubuntu1_arm64.deb
/var/cuda-repo-ubuntu1804-11-6-local/./libnvidia-gl-510_510.47.03-0ubuntu1_arm64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any solution ?

Which jetpack is in use here?

Respected @WayneWWW,
Jetbot OS - jetpack 4.3

Why does a jetpack 4.3 apt-get update trying to install 32.7.1 related software? Are you sure you are running 32.4.3?

Did you ever manually install any NVIDIA video/GPU drivers? Or were all such drivers installed via JetPack/SDK Manager (or command line “apt” versus downloading a “.deb” file)?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.