Eclipse based IDE for ubuntu 16.04

Hi,
I have Ubuntu 16.04 host machine and Tx2 evaluation module. I would like to bring up a remote development setup with my host machine Ubuntu 16.04 with Eclipse based Nvidia nsight IDE. I have tried to install jetpack L4T 3.1 on my ubuntu machine. It installed except vision works pack. Then I have followed this link, but I am facing issues.

My question is, will Eclipse IDE supports ubuntu 16.01?

I have tried to execute the update command,

sudo dpkg --add-architecture aarch64
sudo apt-get update

I am getting the following error.

N: Skipping acquire of configured file ‘restricted/binary-aarch64/Packages’ as repository ‘http://security.ubuntu.com/ubuntu xenial-security InRelease’ doesn’t support architecture ‘aarch64’

Any help or suggestion?

Thanks,

Jebaraj

You might want to ask this question on a the TX2 forum.