eclipse juno and plugin installation

Hello,

I run eclipse Juno on suse linux13.1 and use the latest pgi workstation.
When I try to install the plugin for eclipse an error comes up saying " could not find pgi2014.jar" . Could you help with this?

sorry I made a mistake, its eclipse Kepler, not Juno

Hi a_bra

When you use the Install New Software diaglog, please make sure that the
“Group items by category” box is NOT ticked. This should allow you to see the plugin after you “Add” the local directory in the PGI distribution where the plugin is (/opt/pgi/linux86-64/2014/eclipse/cdt8)

-dave

Dear Dave,

thank you,
I exactly did this and the installation starts and shows what it’s going to install and then stops with the missing file error

Interesting. I had just installed this from 14.6 a few days ago on a Ubuntu 12.10 system in a Kepler Eclipse. Are you pointing to the cdt8 directory, or entering the name of the plugin itself (as the plugin has a different name then what is showing for you). Is the name and directory structure of your cdt8 directory the same as below?

It sounds like the only difference is you have SuSE rather then Ubuntu. Not sure if that would make a difference.

My procedure was to Help -> Install new software

Make sure “Group items by category” is not ticked

Add
Local -> Browse -> point to /opt/pgi/linux86-64/2014/eclipse/cdt8 (not one of the subdirectories) -> OK

This brings up the PGI plugin in the Install dialog
Tick the box to select the PGI plugin -> Next

When the “Unsigned content” box comes up, just click OK.


The contents of my /opt/pgi/linux86-64/2014/eclipse/cdt8 directory:


ls -lt /opt/pgi/linux86-64/2014/eclipse/cdt8/*
-rw-rw-r-- 1 921 1004 595 Jun 3 09:02 /opt/pgi/linux86-64/2014/eclipse/cdt8/artifacts.jar
-rw-rw-r-- 1 921 1004 7367 Jun 3 09:02 /opt/pgi/linux86-64/2014/eclipse/cdt8/content.jar
-rw-r–r-- 1 root root 1291 Jan 15 11:35 /opt/pgi/linux86-64/2014/eclipse/cdt8/artifacts.xml
-rw-r–r-- 1 root root 37230 Jan 15 11:35 /opt/pgi/linux86-64/2014/eclipse/cdt8/content.xml

/opt/pgi/linux86-64/2014/eclipse/cdt8/plugins:
total 140
drwxr-xr-x 2 root root 4096 Jul 8 18:37 META-INF
-rw-rw-r-- 1 909 1004 14195 Dec 10 2013 com.pgroup.plugin_2014.0.0.jar
drwxr-xr-x 3 root root 4096 Dec 4 2013 com
-rw-r–r-- 1 root root 105068 Dec 4 2013 plugin.xml
-rw-r–r-- 1 root root 161 Oct 22 2013 about.ini
drwxr-xr-x 3 root root 4096 Oct 22 2013 OSGI-INF
-rw-r–r-- 1 root root 47 Oct 22 2013 temp_logo.gif

/opt/pgi/linux86-64/2014/eclipse/cdt8/features:
total 52
-rw-rw-r-- 1 909 1004 12723 Dec 10 2013 com.pgroup.plugin_2014.0.0.jar
-rw-r–r-- 1 root root 408 Dec 4 2013 category.xml
-rw-r–r-- 1 root root 15516 Dec 4 2013 feature.xml
-rw-r–r-- 1 root root 14342 Dec 4 2013 LICENSE_Linux.html

Dear Dave,

thanks for the detailed info.

I think the problem is that most of the files you mentioned are missing in the new release. I downloaded pgilinux-2014-146-x86_64.tar.gz and unpacked (no installation) the linux-eclipse.tar.gz, the plugin directory is empty e.g. as well as the features dir. So probably this is the problem?

Best

A

Thanks for pursuing this.

It looks like we dropped the Eclipse files from the installation tarballs a few releases back - and I didn’t notice as they must have been in my personal install from some earlier release.

This should be fixed in the 14.7 release which I expect to be out within the next few weeks.

If you need the content before them - please send your email address to trs@pgroup.com and ask them to forward to Dave in engineering and I’ll email a tarball of the files.

Sorry for missing this.

-dave