Eclipse nisght content assist works but does not highlight current choice

I just installed CentOS 7 with cinnamon desktop on my computer. I then went and installed cuda 7.5. When I opened eclipse nsight I tried coding something to test my install. I started typing and hit Ctrl+Space to get the auto complete menu which came up and had all the correct options. The only issue was that eclipse was not highlighting the current option in the list. I hit enter then the first option completed what I was typing. I then tried again only this time I hit the down arrow key 3 times and then enter and the third option completed what I was typing. The issue here is that eclipse is not highlighting what the selected option is when I move through them.

Here is an image I took of my screen. See how when I start to type “cuda” I get a list of options but the currently selected one does not have highlighting.

The highlighting works great in my normal eclipse luna which I use for everything besides cuda programming. Here is an example of what I want. See how there is blue highlighting around the first option when I hit ctrl+space

Note that I also have Ubuntu on my system. The highlighting works for nsight in ubuntu. Also I tried switching my CentOS from Cinnamon to the GNOME desktop manager and it made no difference. I also tried changing the Prefrences -> General -> Appearance -> Colors and Fonts -> Content Assist Background / Foreground Colors. Not only did this not help but it also did not affect anything. The contents assist remained the same color.

If you want to report a bug I suggest you do it at developer.nvidia.com