Eclipse Nsigh on mac cannot connect via ssh tunnel [SOLVED]


I have this setup:
-my laptop, a MacBook pro running yosemite (called A)
-a gateway running linux (called B)
-a workstation with a CUDA-compatible card (called C).
Firewall policies prevents me from doing ssh directly to C, so usually I ssh to B and the ssh to C.

Now I’m trying to do some remote development&debugging on my laptop, so I have created a tunnel from localhost:2222 to C:22 passing through B:22 by using this command:

ssh -N -f -L 2222:C:22 user@B

now I can ssh directly to C by using ssh user@localhost -p 2222 without typing a password, since I have configured public key authentication.

The problem is that nsight cannot connect to C via this tunnel. I get an error saying
Failed to connect sshd on “”

details are just Failed to connect sshd on “”

this happens when I try to create a new project. I have configured a remote connection, then I hit “Browse”, I’m asked for a password and the the error pops up.

I’ve found a similar problem here ( but it is from more that two years ago.

Nsight is the one supplied by cuda toolkit 7.0.

Any ideas?

Ok, solved. The eclipse version on which nsight is based is very old and I’m using a fairly recent version of openssh, which had disabled some key exchange protocols used by nsight. I solved the issue by adding this line to the sshd configuration file