Edges cut off...Create new resolution profile?

I started using the nano on an older non-standard big screen. The picture is cut off on the borders. What’s the best way to create a new resolution profile to adjust the picture?

Please try to use xrandr to change the resolution first.

I have tried using xrandr, it’s results in bad match error. Although I used cvt 1016 768 to get the right modeline.

Now I am trying to fix with overscan settings,but I am failing.

I was using pi3 for my custom led screen.

I have changed to Jetson just 2 days back, please help.

The overscan is a problem of the display, not of the Nano. You need to turn off overscan on the display.

If the display cannot turn off overscan, then you need to create a virtual X display that uses a framebuffer that’s inset from the physical framebuffer, and have your window manager / session use that display. I have heard that this is possible, but I have no idea how to do it, or how many of the systemd/X configuration files that need to be edited to make something like that go.

Note that the boot-time parameters to inset the framebuffer on the Raspberry Pi are specific functionality of the Raspberry Pi VideoCore support software; those are not standard linux (or even standard VESA) functions.

Since it’s a custom led screen, it doesn’t have any control over overscan. I understand your explanation on raspberry pi but does this mean that it’s nearly impossible to do so ?

I have been reading on viewPortIn settings on Nvidia though I am not successful on it.

Please advice on use of viewPortIn property.

I spent quite an amount and time on Jetson, since it’s not available in India yet. Although i do understand that I should have checked on it before moving on to it.

The best option for you might be to try to add the “Border” option – something like “Border 60,80” in the XRandR / mode setting.
However, it’s not clear whether the Tegra X driver supports that option.
The desktop NVIDIA graphics driver is fairly different from the Tegra graphics driver when it comes to interfacing with memory and the host system, because it’s a different target.

You could also try the ghetto solution:

xrandr --output HDMI-0 --scale 0.9x0.9

I reduced the resolution to 720480. I tried adding new resolution of 720400 60hz but somehow it was added for DP-0 screen not HDMI-0.

On reduced resolution I applied scale of 0.50.5, it kind of worked. But when I ran my app, that runs primarily in kiosk mode, it seems to be unaffected of the settings and it ran with 19201080.

Thank you snarky, for your suggestions, I tried
xrandr --output Screen_name --set Border 0,10,10,0, which didn’t work.
I also tried, setting custom resolution with xrandr which failed every time and with every setting.
The scale option probably won’t give best results as apps don’t seem to inherit it’s effect and it’s not that exact.

With all the above issues, I found out that xrandr is not compatible with nvidia, leading me to nvidia-settings, I was able to get the desired overscan compensation using ViewPortIn and ViewPortOut.

I used this setting, I hope anyone else who faces the same can use it.

nvidia-settings --assign 0/CurrentMetaMode=“DFP-0: 1920x1080 { ViewPortIn=1920x1080, ViewPortOut=1395x1060+0+0 }”

It worked for my exact case, just fiddle with ViewPortOut values and it should set itself.

I am on a Nano too, same issue with an LED screen
I tried devashish668’s fix with nvidia-settings, but it says that the nvidia-settings is not found. I tried installing it, but no success.

How did you install nvidia-settings ?

Thank you.

I don’t exactly recall installing it separately, though it should be straight as sudo apt-get install nvidia-settings.

Thank you, the install worked that way, too simple for the install, I had followed instructions from another website which didn’t work.