EDID issue

Bug originally posted and reported on rpmfusion bugzilla https://bugzilla.rpmfusion.org/show_bug.cgi?id=4183

Overview:
after nvidia driver installation, KDE uses big font size.
Steps to Reproduce:
just need to install nvidia drivers
Actual Results:
the windows display of KDE apps is awfull, big bar title, huge
font used in KDE apps.
Description:
I have troubles with nvidia kmod installation on new fresh fedora 24
installation with KDE. Once the drivers are installed (akmod-nvidia), the
display of the window title bar are huged with huge font, the menu launcher
take 2/3rd of the screen (screen size 1920x1080).
see pictures : https://goo.gl/photos/XRTcsMGCZaDjd62F7

The content of KDE applications (e.g. konsole) uses huge font too while the non
KDE apps (e.g. firefox) uses regular font.

The SDDM loggin screen uses also big font too.

In the KDE config panel, in font management panel, I have an option to “force
font dpi”. If set this option to 96 (my screen dpi), this solves the issue in
kwin window but not for the logging screen.
Before the installation of nvidia driver, the the “focre dpi font” option was
unset.

If i change the dpi with wrandr : $ xrandr --dpi 96. The whole font size
change, leading to normal font size for kde apps and too small font size for
non KDE apps.

$ xdpyinfo | grep inch # without nvidia driver
resolution: 96x96 dots per inch

$ xdpyinfo | grep inch # without nvidia driver
resolution: 305x305 dots per inch

My graphic card is NVidia GTX 750Ti, my screen Sync Master P2370.

People at rpmfusion suspected EDID issue and adviced to report the bug upstream:

Hi, It looks like an edid issue, this should be report to the nvidia dev site I
liked to earlier.
[     8.853] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[     8.858] (--) NVIDIA(0): DPI set to (304, 304); computed from "UseEdidDpi"
X config
[     8.858] (--) NVIDIA(0):     option

To override the edid from the monitor see the info below

https://wiki.archlinux.org/index.php/xorg#Proprietary_NVIDIA_driver


Then create the file and add this

http://paste.fedoraproject.org/406905/71013309/raw/

After the edit Xorg will need restarting.

Updating the file /etc/X11/xorg.conf.d/99-nvidia.conf to
add a section:

Section "Device"
    Identifier  "Videocard0"
    Driver      "nvidia"
        Option      "UseEdidDpi" "False"
        Option      "DPI" "96 x 96"
EndSection

This trick did the job!

the log is available at original bug post on above rpmfusion link

I don’t know that I’d call this a bug. The driver is reporting the size reported by the EDID. Without the NVIDIA driver, something is presumably hard-coding a (incorrect) DPI of 96. There’s a whole appendix in the README about DPI issues and how to override incorrect EDID DPIs: http://us.download.nvidia.com/XFree86/Linux-x86/370.28/README/dpi.html