(EE) no screens found, 450.57, ubuntu kernel 4.15.0

This is a lenovo laptop with Quadro RTX 4000. Installing ubuntu-drivers by Software Center does not work, so I used a .run file. Before a kernel auto-update I used an xorg.conf with a self defined ModeLine, ConnectedMonitor and CustomEIDD to directly load the inbuilt display screen. After the update, if I continue to specify the EDID file there is an error about ‘failed to set screen _icc_profile failed to open file permission denied’. Now I cannot recover the original state that loads a display with nvidia drivers installed. Reinstalled ubuntu afterwards, but still the same errors appear.

Display device seems to be unable to connect. Startx fails with a (EE) no screens found, and Xorg.0.log approximately loads like this:

[ 351.785] (II) xfree86: Adding drm device (/dev/dri/card0)

[ 351.787] (–) PCI:*(-@-:2:0) 8086:3e96:17aa:229b rev 2, Mem @ 0xe9000000/16777216, 0xc0000000/268435456, I/O @ 0x00003000/64, BIOS @ 0x???131072

(II) “glx” will be loaded. This was enabled by default and also specified in the config file.
LoadModule “modesetting”
Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so

LoadModule: “glx”, “nvidia”,…
[351.787] (WW) Falling back to old probe method for modesetting
loading sub module “fb”…sfb, ramdac,
Option “AllowNVIDIAGpuScreens” … glxserver_nvidia
The X server supports PRIME Render Offload
Valid display devices(s) on GPU-0 at PCI:1:0:0
DFP-0 …
DFP-1 …
DFP-2 …
NVIDIA GPU Quadro RTS 4000 (TU104GL-A) at PCI:1:0:0 (GPU-0)

DFP-0: disconnected
DFP-0: Internal DisplayPort

Based on nvidia-xsetting
Section Module has “modesetting” and “glx”; section Device has an extra line “BusID "PCI:1:0:0"

nvidia-bug-report.log (658.3 KB)

It’s a hybrid graphics notebook. Please delete xorg.conf and remove the ‘nomodeset’ kernel parameter.

Problem perfectly solved… Thank you