EGLDevice graphics demo doesn't work correctly with 1920x1080@30 display mode


I’ve tried gears demo with EGLDevice backend.
When I set resolution and refresh rate as 1920x1080@30, HDMI output signal was incorrect.

I’ve connected Jetson NX HDMI output to Magewell USB Capture HDMI gen 2.
Then start gears demo.

$ prebuilts/bin/egldevice/gears -res 1920 1080 -refresh 30
Alpha value specified for constant blending is not in range [0, 1]. Using alpha 1.0.
Demo Mode: 1920 x 1080 @ 24
 running for 5.000000 seconds...
Total FPS: 24.600000

It seems that resolution is correct. But refresh rate is not correct.

And I checked Magewell utility. That shows incorrect display mode (1920x2205p24).

Output is like this.

I confirmed this problem on JetPack 4.5.1 and 4.6.2.
Is there any way to get correct output?

Please try to connect to a HDMI TV and check if you can observe the issue. To clarify if it is specific to using the HDMI capture card. And the latest Jetpack 4 release is 4.6.3. You may upgrade and give it a try. May also try Jetpack 5.1.1.

Sorry for late response.

I’ve tried to connect to BlackMagic VideoAssist 12G. I observed similar issue with VideoAssist.
When I connect to HDMI input of VideoAssist, Console output was fine. gears app with 1920x1080p60
display mode works fine. But with 1920x1080p30 display mode, display had no output and VideoAssist
shows “Not supported”.
And I’ve tried JetPack 4.6.3 and JetPack 5.1.1, but both not works.