EKB Generation in L4T 32.4.4

Hi guys,

I’m using JetPack 4.4.1 and trying to generate the EKB as described in the Nvidia documentation.

The tool gen_ekb.py is not found.

$ python3 gen_ekb.py -kek2_key <kek2_fuse_key_file> \
    -fv <fv_for_ekb_ek> \
    -in_sym_key <sym_key_file> \
    -out <eks.img file>

I already checked in the following packages:

Could you please provide the tool gen_ekb.py ? or share where I can find it ?

Best regards,

May I know which Jetson Platform you’re using?

Hey @kayccc

I’m using Jetson Nano, Jetson TX2, Xavier NX and Xavier AGX.


OK, the Jetson project forum is for sharing, not for issue resolution.
Moving to Jetson AGX forum as start.

1 Like

Thanks @kayccc

I’m planning to develop a TA based on the latest sample code provide by Nvidia team to use the SSK via the Trusted OS.

hello ilies.chergui,

here it is…

Thanks @JerryChang

Hey @JerryChang

I tried the gen_ekb.py and I got an issue. I’m using Ubuntu 18.04.5 LTS

  • Here is the traces:
$ ./example.sh                                         
Traceback (most recent call last):
  File "gen_ekb.py", line 32, in <module>
    from Crypto.Cipher import AES
  File "/usr/lib/python3/dist-packages/Crypto/Cipher/AES.py", line 50, in <module>
    from Crypto.Cipher import _AES
ImportError: cannot import name '_AES' from 'Crypto.Cipher' (/usr/lib/python3/dist-packages/Crypto/Cipher/__init__.py)

This happen because I’m using an old version of python3-cryptography

$ pip3 list | grep -i "crypto"
asn1crypto                    0.24.0
cryptography                  2.1.4
pycrypto                      2.6.1

We should use a recent version of the python3-cryptography
I tried with the following version and it works fine.

$ python3 -m pip list | grep -i "crypt"
cryptography 3.0
pycrypto     2.6.1

Thanks for your support