emmintrin.h not found in TX2

I installed Jetpack3.0 on my TX2,when I try to run the code,it shows emmintrin.h No such file or directory. what should I do?

Hi 2532392054,

The JetPack runs on the host Ubuntu x86_64 machine, not on Jetson, it’s to set up your development environment and Jetson TX2, please refer to the installation guide:
http://docs.nvidia.com/jetpack-l4t/index.html#developertools/mobile/jetpack/l4t/3.0/jetpack_l4t_install.htm

BTW, why you want to use Jetpack3.0? We have a newer release, please check: https://developer.nvidia.com/embedded/jetpack

Thanks

I flesh it in the toolkit,the latest release will cause reboot problem.What I want to know is that how can I run the project?

Hi 2532392054,

Sorry, I don’t understand what project you want to run?
Are you install JetPack3.2 DP package hit reboot problem?
Please provide more detail about your problem.

Thanks!

I have fixed emmintrin.h not found problem by replace it by NEON2SSE.h
found in here https://github.com/jratcliff63367/sse2neon/blob/master/SSE2NEON.h
no problem in jetpack.

I try to replace it bu SSE2NEON.h, but there is another problem
aarch64-linux-gnu-gcc: error: unrecongnized command line option ‘-mfpu=neon’
Have you encountered this problem, how did you solve it?
Thank you very much

I have solved the problem
the solution can be found here ,https://stackoverflow.com/questions/29851128/gcc-arm64-aarch64-unrecognized-command-line-option-mfpu-neon
thank you