Empty Jetpack Install

Hello, I have used sdk manager to install jetpack 4.2. I have worked through the install process and successfully completed the install through flashing the Jetson. I have discovered that my JetPack_4.2.Linux_* director under /nvidia/nvidia_sdk/ is empty. Therefor I have no flash.sh script or anything else that should be there. I do have some documentation under the JetPack_4.2.Linux directory. I have tried to reinstall jetpack onto the host machine a 2nd time and the directory is still empty.

Anyone else have this issue? Help resolving the issue would be appreciated. Thanks.

Hi Dustin_S_Houck,

Could you try remove below two path and run sdkmanager again?

$ sudo rm -R /home/<user name>/nvidia/nvidia_sdk/
$ sudo rm -R /home/<user name>/.nvsdkm/

It still only brought down the JetPack_4.2.1_Linux_GA folder with documentation.

Ok, I think I have it fixed now, I had to make sure I reset up both the host machine and Target hardware (did not reflash jetson) after deleting the directories/files you specified.



I have been experiencing the same problem and the solution doesn’t work for me. Anyone else have this issue?

For those directories to be added SDK Manager would need internet access. There is a manifest which is downloaded, and then the items on the manifest which apply to whatever options have been picked will cause the other downloads. If there is any kind of firewall or proxy issue, then the downloads would fail and the content would never be created. Do you have any kind of firewall or proxy?

Yes, there is a proxy server in the company. However I did install perfectly in the past. I needed to refresh ubuntu 16.04 of my host pc and after the new setup, I cannot dowload the sdk components.

I can enter my proxy settings to sdkmanager and can login to download the components.

I don’t know how to debug proxy settings under SDKM (I don’t use a proxy), but perhaps someone with proxy experience on SDKM can suggest why those settings might work for login, yet fail for actual component install.


what is the reason of this solution?

I installed fresh ubuntu 18.04 and the problem still remains.

Removing those directories would help if a prior attempt to use SDKM left corrupt or incomplete files (such as if a network connection failed in the middle of an operation).

I still suspect something related to the firewall/proxy setup is at issue. Sometimes one network operation might seem to work, and yet the same proxy will fail if a different port is used (and I suspect that the proxy is correct in setup for only part of the involved ports, but I couldn’t tell you which ports those would be).