Emulate IP camera using test-launch but having issues in playing the video stream

source8_1080p_dec_infer-resnet_tracker_tiled_display_fp16_nano_rtsp_test.txt (4.0 KB) • Hardware Platform (Jetson / GPU) : Jetson Xavier NX
• DeepStream Version: 5.0
• JetPack Version (valid for Jetson only) : nvidia-jetpack, 4.4-b186
• TensorRT Version : 7.0
• NVIDIA GPU Driver Version (valid for GPU only) :

Hello Dane,

I was reading this post thread and would appreciate if you can offer any advise in my test here.

1). I use test-launch to start a rtsp stream server. commands used;
./test-launch "filesrc location=/home/user/Downloads/my_car/VID_20200705_144040.mp4 ! qtdemux ! rtph264pay name=pay0 pt=96 "

2). on a remote PC, I am able to view the rtsp stream using vlc player.

3). on the Jetson Xavier NX module locally, I use below command to play the rtsp stream locally:
gst-launch-1.0 rtspsrc location=rtsp://username:password@ ! rtph264depay ! h264parse ! omxh264dec ! nveglglessink

sometimes it can display the video, but the image seems to be distorted.
sometimes it simply does not show any video in the elgsink.

4). the ultimate aim of this test is to emulate an IP camera for deep-stream test.
I will use test-launch(in 1). above) to launc a rtsp stream server.
and I would need to use the rtsp as source for my deepstream-app test.

5). I enclosed the file that I used. if I use local file as source, the video can display correctly.
but if I use rtsp stream, again, the elgsink has no video display. and it simply shows frame rate =0.

I would appreciate if you can advise on questions 3) and 5) above.

thank you.

You may refer to this post:

And for launching RTSP server through test-launch, you should not need username and password. The uri should be


You may try uridecodebin in gst-launch command:

$ gst-launch-1.0 uridecodebin uri=rtsp:// ! nvoverlaysink

Hi Dane LLL,

Thank you for your support.

1). I tried this command: $ gst-launch-1.0 uridecodebin uri=rtsp:// ! nvoverlaysink

It can display the video in the Eglsink easier; but it still have two issues: 1). the video displayed always get blurred and distorted. pls see enclosed pic 1. 2). sometimes the command does not launch the eglsink successfully.

2). I tried using urt=rtsp:// in the configure.txt file for source0 configuration.
the issue persists that the Eglsink opens, but no video display. please see enclosed pic 2.

thank you.
Mei Guodong

Dear Dane LLL,

one more enquiry, when use gst-launch-1.0, it always launches the Eglsink in full screen mode. how do I escape from the full screen of the display, or how do I launch the Eglsink in non-full-screen mode?

Thank you.

We don’t observe the same issue on Jetpack4.4 DP + DeepStream SDK 5.0 DP. JP4.4 GA is just released and DS5.0 GA is going to be released soon. You may wait for DS5.0 GA.