Emulation Mode On a CUDA capable macbook pro???

I am running off of a macbook pro with an 8600m GT card, which is certainly compatible with cuda. When I run an example application from the sdk, I get the following distressing line of output:

Using device 0: Device Emulation (CPU)

I am on 10.5.5, and there is no indication on the download page that I should install a driver. I built all of the examples by:

cd /Developer/CUDA

Why, in that case, are these applications all running in emulation mode?


You need to install the toolkit.

What do you mean, “install the toolkit?” I, too have this problem. I have installed:

[indent] 1) NVIDIA_CUDA_Toolkit_MacOSX.pkg

  1. NVIDIA_CUDA_SDK_2.02.0807.1535_MACOSX.pkg[/indent]

I have done the “make” without errors. All the sample codes compile, but some don’t execute properly and several have this “There is no device supporting CUDA” message. I using a MBP with OS 10.5.5. The system profiler says the following for graphics:

[indent][indent]GeForce 8600M GT:

Chipset Model: GeForce 8600M GT

Type: Display

Bus: PCIe

PCIe Lane Width: x16

VRAM (Total): 128 MB

Vendor: NVIDIA (0x10de)

Device ID: 0x0407

Revision ID: 0x00a1

ROM Revision: 3175


This device is listed as being supported.

If I execute deviceQuery, it reports:

[indent][indent]There is no device supporting CUDA.

Device 0: “Device Emulation (CPU)”

Major revision number: 9999

Minor revision number: 9999

Total amount of global memory: 4294967295 bytes

Number of multiprocessors: 16

Number of cores: 128

Total amount of constant memory: 65536 bytes

Total amount of shared memory per block: 16384 bytes

Total number of registers available per block: 8192

Warp size: 1

Maximum number of threads per block: 512

Maximum sizes of each dimension of a block: 512 x 512 x 64

Maximum sizes of each dimension of a grid: 65535 x 65535 x 1

Maximum memory pitch: 262144 bytes

Texture alignment: 256 bytes

Clock rate: 1.35 GHz

Concurrent copy and execution: No


Press ENTER to exit…[/indent][/indent]

I’m not sure what else there is to do to get the GPU to execute the code.

Reinstall the toolkit and check that CUDAKext is being installed ( when the Installation Type screen is active, press the Customize button).
The machine should reboot after a proper installation.

I’m running into a similar problem. I reinstalled the Toolkit twice now. Under customize, all of the boxes are checked by default and the CUDAKext is installed.

It’s a MB Pro, 10.5.5, GeForce 8600M GT card. The deviceQuery returns “1 device supporting CUDA” and that’s the aforementioned card.

I remade the examples in the /Developer/SDKs/NVIDIA_CUDA_SDK_MACOSX directory, tried to run them and I get the message “There is no device supporting CUDA.” When I tried to run the simpleGL example, it will open, but then it says “Error when parsing command line argument string.”

The PATH is setup. It was setup when I ran CUDA 1.1 (which did work), and in the .profile the following is present:

export PATH=/usr/local/cuda/bin:$PATH

export LD_LIBRARY_PATH=$LD_LIBRARY:/usr/local/cuda/lib

I’m not sure what to do other than to try and reinstall 1.1 again and see if that works. If anyone has any ideas, that would be great!