Emulator Failed to Start

I posted this in the XenDesktop area but it may be better suited here:

overview:

server: HP SL250s Gen8 [BIOS P75]
CPU: 2x E5-2670 v1
RAM; 96GB
HDD: 2x 1TB SSD
GPU: Nvidia Grid K2
Host OS: XenServer 7.0.0 Enterprise
Guest OS: Windows 10 Exterprise Edition
vGPU Profile: K220Q

vdi001, vdi002, vdi003, vdi005, vdi006, vdi007

The above won’t start unless the VM is set to NONE for the vGPU. It shows the following error:

An emulator required to run this VM failed to start

If 2 VM’s are set to NONE for the vGPU and 1 is running then it shows the following error when trying to start the 2nd VM:

Internal error: xenopsd internal error:Unix.Unix_error(Unix.ENOSPC,"write","")

I currently have 3 other VM’s on this server running as NONE for the vGPU so I know I can have more than 1 running with NONE set. I have 4 VM’s running with the K220Q profile on a Grid K2 card [allows for 16 VM’s running this profile on a single K2 card]. Yesterday I had 10 running with the K220Q profile and teh other 3 running with NONE. That worked fine then it crapped out today and I haven’t been able to recover it yet.

I thought perhaps it may be a driver issue. I reverted vdi007 to a snapshot from yesterday and that did not change the behavior. I deleted vdi007 and created a new one from the master snapshot image that all of the VM’s were created from and that did not change anything.

I shutdown vdi008 [running the K220Q profile] and tried to start vdi007 again but get the same emulator error. vdi008 will not start now either and shows the emulator error.

You don’t specify which driver bundle you are using, or whether this affects earlier versions of XenServer.

For XenServer 7.0 you must have - Windows Display Driver (362.56) and GRID vGPU Manager (361.45.09)

Are earlier versions of XenServer affected?

I’ve seen a similar emulator error associated with a BIOS issue on another manufacturers server. Legitimate changes in XenServer 7.0 exposed a previously latent issue in the BIOS and required a BIOS update. http://nvidia.custhelp.com/app/answers/detail/a_id/4163/kw/emulator

It may well be worth checkign with HP and Citrix if there are any known issues/BIOS updates.

Rachel

The issue has been resolved. The /run partition was fI’ll due to a misplaced snapshot. This was cleared up and the write errors were resolved. A reboot of the syst em was performed and the emulator errors were resolved.

/run was full**

System**

Sorry for the typos.

Hey Josh - Glad you got it sorted! And thank you for helping others by identifying the cause and coming back to share :-D We like you!!!

That error message can also appear apparently if modeswitching hasn’t been done on new M60/M6 cards as per: http://nvidia-esp.custhelp.com/app/answers/detail/a_id/4106