Enable CAM0_MCLK on A02 devkit board

I’m trying to enable a 24Mhz MCLK on CAM0_MCLK. But whatever I do, the signal stays low.
In pinmux, the pin is enabled.

pinmux_default: common {
cam1_mclk_ps0 {
nvidia,pins = “cam1_mclk_ps0”;
nvidia,function = “extperiph3”;
nvidia,pull = <TEGRA_PIN_PULL_NONE>;
nvidia,tristate = <TEGRA_PIN_DISABLE>;
nvidia,enable-input = <TEGRA_PIN_DISABLE>;

And in my driver (not a CAM driver!) I enable the extperiph3 clk.
In my dts:
clocks = <&tegra_car TEGRA210_CLK_EXTERN3>;
And in my driver I start clock with clk_prepare_enable().

Any pointers I could check?

hello Sbuteo,

please refer to Nano Product Design Guide and check the [Table 7-2] for mclk descriptions.
you should also check Nano’s dual-camera reference driver, thanks
for example,

The example tegra210-camera-rbpcv2-dual-imx219.dtsi doesn’t do anything to enable an mclk.
The problem I was facing, was a incorrect clock name. It seems that some name changes has been done from the time my example dts file was created.

For anyone else, with the next clock setting I have made it working.

clocks = <&tegra_car TEGRA210_CLK_CLK_OUT_3>, <&tegra_car TEGRA210_CLK_PLL_P>;
clock-names = “mclk”, “parent_clk”;