Enable dma for rx in uart 4 (ttyTHS3)


We are trying to enable using dma for rx in uart 4. This is the bindings we changed:

serial@3130000 {
dma-names = “rx”, “tx”;
status = “okay”;

We see a strange behaviour when using flow control. The rts pin of the jetson not rising to 3.3V. We test ttyTHS2 in the development kit and everything worked. In addition, the dma mode for rx was already configured. We are wondering why rx was not enabled for dma in uart 4 and if our issue is known.


hello covigoj430,

may I know the baudrate settings you’re used.
please also check discussion thread, such as Topic 154947 for reference,

thanks for the fast reply!
I am using 4Mb baudrate with 2 stop bits in uart4. We also enabled the dma options for the rx.