Enable HD resolution with no display connected

Hi, I have a peculiar use case: a headless machine (home server).
In dropped in a 1060, connected a display and set up a (limited) account for Steam. Then, I connected steam link (read: VNC-like streaming games, it clones primary display via LAN) to TV and it worked superb.
Then, when everything worked great, I disconnected the display, put the server back into its place…and without display connected, it only starts in 640x480 mode.

I tried adding modelines & modes to xorg.conf with no success. Do I have to buy a dummy HDMI dongle (it sends fake EDID data), or can I set it up in xorg.conf?

Here are my current (relevant) settings:

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    HorizSync   30-85
    VertRefresh 48-120

        ModeLine        "1920x1080" 148.35  1920 2008 2052 2200 1080 1084 1089 1125
    ModelName      "Unknown"
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    Option      "AllowEmptyInitialConfiguration"
    VendorName     "NVIDIA Corporation"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option      "ModeValidation" "AllowNonEdidModes, NoVesaModes"
    Option      "MetaModes" "1920x1080"
    SubSection     "Display"
        Depth       24

But it just doesn’t work. Here’s excerpt from Xorg.0.log:

  2164.901] (WW) NVIDIA(0): No valid modes for "1920x1080"; removing.
[  2164.901] (WW) NVIDIA(0): 
[  2164.901] (WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
[  2164.901] (WW) NVIDIA(0):     "nvidia-auto-select".
[  2164.901] (WW) NVIDIA(0): 
[  2164.901] (--) NVIDIA(0): No enabled display devices found; starting anyway because
[  2164.901] (--) NVIDIA(0):     AllowEmptyInitialConfiguration is enabled
[  2164.902] (II) NVIDIA(0): Validated MetaModes:
[  2164.902] (II) NVIDIA(0):     "NULL"
[  2164.902] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480

Can I “force” it to use 1920x1080 (or any other) mode without monitor (or fake HDMI dongle) connected?

You can use the ConnectedMonitor and CustomEdid options to fake a monitor

1 Like

Thanks, that worked like a charm!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.