Enable pwm through sysfs on agx orin , but no signal

Hi teams,

I am trying to control PWM through sysfs, but I can’t measure any signal on the oscilloscope.
Below are the PWM-related information and pinmux settings that I have configured. My BSP version is Jetson_Linux_R35.3.1.

                    soc_gpio37_pr0 {
                            nvidia,pins = "soc_gpio37_pr0";
                            nvidia,function = "gp";
                            nvidia,pull = <TEGRA_PIN_PULL_NONE>;
                            nvidia,tristate = <TEGRA_PIN_DISABLE>;
                            nvidia,enable-input = <TEGRA_PIN_DISABLE>;
                            nvidia,lpdr = <TEGRA_PIN_DISABLE>;
                    };
                    soc_gpio39_pn1 {
                            nvidia,pins = "soc_gpio39_pn1";
                            nvidia,function = "gp";
                            nvidia,pull = <TEGRA_PIN_PULL_NONE>;
                            nvidia,tristate = <TEGRA_PIN_DISABLE>;
                            nvidia,enable-input = <TEGRA_PIN_DISABLE>;
                            nvidia,lpdr = <TEGRA_PIN_DISABLE>;
                    };

root@adlink-desktop:/sys/class/pwm/pwmchip0/pwm0# cat /sys/kernel/debug/pwm
platform/39c0000.tachometer, 1 PWM device
pwm-0 ((null) ): period: 0 ns duty: 0 ns polarity: normal

platform/32f0000.pwm, 1 PWM device
pwm-0 (sysfs ): requested enabled period: 10000 ns duty: 1000 ns polarity: normal

platform/32c0000.pwm, 1 PWM device
pwm-0 ((null) ): period: 0 ns duty: 0 ns polarity: normal

platform/32a0000.pwm, 1 PWM device
pwm-0 (pwm-fan ): requested enabled period: 45334 ns duty: 45333 ns polarity: normal

platform/3280000.pwm, 1 PWM device
pwm-0 (sysfs ): requested enabled period: 10000 ns duty: 1000 ns polarity: normal

Hi,

We have other customer validated soc_gpio37_pr0 before. What file did you update the pinmux? And how did you flash it to your board?

sudo ./flash.sh jetson-agx-orin-devkit mmcblk0p1

tegra234-mb1-bct-pinmux-p3701-0000-a04.dtsi

I found that my demo kit is broken, so this is not a issue .

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.