Enable tristate for pin UART1_TXD

Hi,

We have configured the pin UART1_TXD (pin number 203 in som connector) as gpio input tristate in dtb. The dtb entry for the pin is given as below,

uart1_tx_pr2 {
nvidia,pins = “uart1_tx_pr2”;
nvidia,function = “rsvd1”;
nvidia,pull = <TEGRA_PIN_PULL_NONE>;
nvidia,tristate = <TEGRA_PIN_ENABLE>;
nvidia,enable-input = <TEGRA_PIN_ENABLE>;
nvidia,io-high-voltage = <TEGRA_PIN_DISABLE>;
nvidia,lpdr = <TEGRA_PIN_DISABLE>;
};

We observe the pinmux driver to set this pin in tristate (TEGRA_PINCONF_PARAM_TRISTATE switch case, tegra_pinconf_reg function(), kernel/kernel-4.9/drivers/pinctrl/tegra/pinctrl-tegra.c file), but probing the pin we don’t see tristate is enabled.

Could you please provide any idea on how to proceed this further?

hello yeshwanth.vn,

did you use the pinmux configuration, had you update the cfg file by full flash the target?

Hi,

We have tried writing 0x00000051 in 0x024300a8 in cfg file( tegra19x-mb1-pinmux-p3668-a01.cfg ) and flashed and checked, still we are not able to see that pin is in tristate.

Also we have tried using devmem2 (sudo devmem2 0x024300a8 w 0x00000051), still that pin is not seen in tristate. Please advise us on how to get this resolved.

Hi, how do you measure the pin? Is the GPIO function of this in normal? There is a level shift for this pin on carrier board and also there is a buffer on module.