Enable “use CUDA” for openCV


In ubuntu 18.04 (jetson nano) I have openCV 4.1.1 and CUDA 10.2.89 but when I see the result of below command in python cv2.cuda.getCudaEnabledDeviceCount() it gave me 0 that means opencv dont use CUDA. what should I do to enable “use CUDA” in jetson nano



TensorRT Version :
CUDA Version : 10.2.89
CUDNN Version :
Operating System + Version : ubuntu 18.04
Python Version (if applicable) : 3.6.9
TensorFlow Version (if applicable) : 2.3.1

You would need to manual enable it. Please try this script:
JEP/install_opencv4.5.0_Jetson.sh at master · AastaNV/JEP · GitHub

If you need to use other version, please modify the script accordingly.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.