Enabling c++11 in Nsight Eclipse Version 9

Hi,

I am using Nsight eclipse version 9.
I am not able to set the -std=c++11 flag, can any one help me by answering how to do this?.
I have done a lot of search on google and Nvidia forums but did not get the answers I am looking for.
All the answers i came across are not applicable for version 9 of Nsight Eclipse,they are for older versions of the IDE and I cannot see most of the options for example (ProjectProperties>> Build>> Setting>> Tab: ToolSetting is not available in version 9).

BuildSettings.png

Hi,

You can enable this machine in ProjectProperties>> Build>> Setting>>Tab: ToolSetting>>NVCC Compiler>>Code Generation, there is an option “Enable C++11 support”

Hi Veraj,

Please look at the attached screenshot of the properties window in my original question, I have no “Tab: ToolSetting” option under Setting.
Are you sure your answer is valid for version 9 of Nsight Eclipse? Can you attach some screenshots?

Hi,

Are you using nsight standalone application or use nsight plugin in eclipse ?

It is the one that was available when I installed all the packages using Driveinstall and can be found in the folder: /usr/local/cuda/bin. So it is nsight standalone application.

Hi, shivaram

This is an set up issue. There must be something wrong with your env.

Actually the “Tools Settings tab” is not provided by nsight but the eclipse.

Can you check if you have /usr/local/cuda/jre folder ?

Hi Veraj,

These are the files and folders under …/…/cuda/ , I dont see jre in there.

bin lib64 nsightee_plugins README targets doc libnsight NVIDIA_SLA_cuDNN _Support.txt samples tools extras libnvvp nvml share version.txt include LICENSE nvvm src

Can you elaborate a bit on how I can work towards getting(/jre) it installed?

Hi,

Can you tell me
1)java version on your machine
2)the steps you create the project ?
3)I know you are using CUDA 9, which is the exactly version ?
4)OS
5)Any configuration you have change before launch nsight ?

Also as you see nsightee_plugins folder. I suggest you try with this. It can be installed in eclipse.

  1. Get an eclipse, if you are using 9.0, please get eclipse 4.4/4.5. If you are using 9.1,please get 4.6/4.7
  2. Help->Install New Software->Add->Fill name as ‘nsight’->Location choose the zip under /usr/local/cuda/nsightee_plugins, then follow the instructions to finish the installation
  3. launch eclipse to check if these tabs occurs.

Hi Veraj,

There is something strange with Nsight, I do not know if it is meant to be like that.
i.e. When I create New project, I can see the Tab:ToolSettings under project properties>>build, as I start configuring the project properties (I followed: https://devblogs.nvidia.com/drive-px-nsight-eclipse-edition/), the tab disappears.

To summarize, I did none of the changes from the above comment of yours. I check the check box for enabling c++11 as soon as create a New project, and then make other changes in the project properties. I was able to build without any warnings or errors.

Thanks for you support and quick responses.

Glad your problem solved.

Hi,shivaram.singh.rajput

I have the same problem and follow the description,“create a New project” to solved it.
Now,the other problem is WindowGLFW.hpp fatal error:“GLFW/glfw3.h:NO such file or directory”.
Do you have some idea?

Hi Yurui,

Looks like you have not included all headers. Can you try building it after including all the headers under framework folder?

Hi,shivaram.singh.rajput

I have solved it as you suggest.Thanks!

Hi

I have a different problem for the nsight plugin.
I installed the plugin to Eclipse Photon. But whenever, I tried to program device code. Cuda parser crash. Does anyone in the community is facing the same issue?