Enabling HDMI for AGX Orin


We are testing our carrier board for AGX Orin Module.
Previously, the hdmi could be enable as follows:

Current kernel source (JP5.1.1/L4T35.3.1) has no hdmi dcb file.
There are two files for dcb.

I checked “_hdmi” and “_dsi” are not matched.
Which dcb file do I need to use for enabling HDMI?

If this is too hard for you, please check the post here.

The file name is never something matters in the device tree world once you know how things work.

Sorry that the post have some comments in Mandarin.

I tried to be enable hdmi from what you shared.
Only single point is changed in kernel source code file as below:
tegra234-p3701-0000-p3737-0000.dts => tegra234-p3701-0004-p3737-0000.dts

Anyway, It doesn’t works for enabling HDMI.
Could you check the booting log?
jp5.0.2_boot_log.txt (90.6 KB)

And you can see what system message be gotten when the hdmi cable has reconnected.
dmesg.txt (126.0 KB)

please use jp5.1.1 instead of jp5.0.2. JP5.0.2 has a known issue that some mismatch dtb and pinmux would be used for wrong module.

Also, There is nothing to check from dmesg with Orin display.

You can only make sure the DCB, pinmux are set correctly. If you are sure it is set correctly, then it is not a software issue. It is hardware issue.

Actually, I tried to flash both jp5.1.1 and jp5.0.2.
The boot log are very close to be same.

Ok, I would check both DCB and Hardware Design.

Hello, Wayne.

We’ve found some dismatched data line connection.
Connection has fixed and then nvidia logo is showing on the monitor while doing EFI sequence.

After EFI, hdmi display doesn’t bring up from kernel.

I think we need to set correct HDMI Enable Pin setting.
This is the our schematic.

The HDMI Enable Pin is GPIO(A, 3),
It is DP Enable Pin with default device tree.

The HDMI design guide looks HDMI Enable pin woks to input enable.
But our design is close to DP reference design than HDMI reference design.

So, our hardware engineer told me, It can display out if the HDMI Enabler Pin is High.
And GPIO(A, 3) is enable from fixed regulator setting as a default.
But it doesn’t work for display out.

And I tried to set as follows:

But It doesn’t works.

How I can set Output High for HDMI Enable Pin?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.