Enabling LSF compatible OpenMPI in LAMMPS


I am trying to build the LAMMPS Dockerfile, found in /usr/src of your Docker container, with an LSF-enabled OpenMPI. Currently, I modified the Dockerfile as follows:

# Setup LSF link libraries
COPY lsf/10.1 /opt/ibm/lsfsuite/lsf

# https://github.com/open-mpi/ompi.git
RUN mkdir -p /var/tmp && cd /var/tmp && git clone --depth=1 --branch v4.1.1rc1 https://github.com/open-mpi/ompi.git ompi && cd - && \
    cd /var/tmp/ompi && \
    ./autogen.pl && \
    cd /var/tmp/ompi &&  CC=gcc CFLAGS='-march=haswell -mtune=generic -O3 -pipe' CXX=g++ CXXFLAGS='-march=haswell -mtune=generic -O3 -pipe' F77=gfortran F90=gfortran FC=gfortran FFLAGS='-march=haswell -mtune=generic -O3 -pipe' LDFLAGS=-Wl,--as-needed ./configure --prefix=/usr/local/openmpi --disable-debug --disable-getpwuid --disable-mem-debug --disable-mem-profile --disable-memchecker --disable-oshmem --disable-static --enable-mca-no-build=btl-uct --enable-mpi-thread-multiple --enable-mpi1-compatibility --prefix=/usr/local/openmpi --with-cuda=/usr/local/cuda --with-pmi=/usr/local/pmi --with-slurm --with-lsf=/opt/ibm/lsfsuite/lsf --with-ucx=/usr/local/ucx --without-verbs && \
    make -j$(nproc) && \
    make -j$(nproc) install && \
    rm -rf /var/tmp/ompi

I encounter this error

52 250.8 --- MCA component ess:lsf (m4 configuration macro)
#52 250.8 checking for MCA component ess:lsf compile mode... dso
#52 250.9 checking --with-lsf value... sanity check ok (/opt/ibm/lsfsuite/lsf)
#52 250.9 checking --with-lsf-libdir value... simple ok (unspecified value)
#52 250.9 checking for library containing yp_all... -lnsl
#52 251.0 checking lsf/lsf.h usability... yes
#52 251.0 checking lsf/lsf.h presence... yes
#52 251.0 checking for lsf/lsf.h... yes
#52 251.0 looking for library in lib
#52 251.0 checking for library containing ls_info... no
#52 251.1 looking for library in lib64
#52 251.1 checking for library containing ls_info... no
#52 251.2 checking for libevent conflict... No. Internal Libevent or libevent_core is being used.
#52 251.2 configure: WARNING: LSF support requested (via --with-lsf) but not found.
#52 251.2 configure: error: Aborting.

Can you please help me to enable an LSF-compatible MPI? I’ve also used MPICH in the past and found that to work more often. Is that available?
Thank you!