Enabling Switch Ports

I’m new to NVIDIA Mellanox Switches, I am trying to connect Port 1 to my Firewall and the other ports to my servers. For some reason, I am not seeing the port lightning up. Do I need to enable anything to get these ports up? It appears its recognizing a cable is connected to it because it says the cable type/vendor. It does not say its unplugged. Yet, there is no data passing by.

hi amfa
Are you using onyx or cumulus? What is the specific version number

hi amfa
If you are using cumulus, By default, all data plane ports (every Ethernet port except for the management)
Interface, eth0) are disabled
To administratively enable all physical ports, run the following command, where
Swp1-52 reports a switch with switch ports numbered from swp1 to swp52:
cumulus@switch:~$ net add interface swp1-52
cumulus@switch:~$ net pending
cumulus@switch:~$ net commit

I am using Onyx. Do I need some sort of license to get the ports working?

As far as I know, onyx does not require any special settings or licenses
I suggest you send an email to the official TAC to open a case for processing
networking-support@nvidia.com